Start a new topic
Solved

Unity 2020.1 not working with Wikitude 9.3.1

When I start a new project with Unity 2020.1 (tried it with 2020.1.7f1 and 2020.1.9f1) I get the following error in the console.

'/Applications/Unity/Hub/Editor/2020.1.9f1/Unity.app/Contents/Resources/PackageManager/BuiltInPackages/com.unity.ugui/Runtime/UI/Core/Culling/Clipping.cs(26,49): error CS1061: 'RectMask2D' does not contain a definition for 'padding' and no accessible extension method 'padding' accepting a first argument of type 'RectMask2D' could be found (are you missing a using directive or an assembly reference?)' 


Any idea how to fix this?


same error for me

Hi,


This issue will be fixed in the next update of the SDK, which should be available soon. Until then, when importing the Unity package, please make sure that only the 'StreamingAssets' and the 'Wikitude' folders are selected and that the 'Packages' folder is ticked off.

Otherwise, you can also use the provided sample project.


Best regards,

Alexandru

actually, importing the sample project breaks it too, I had to uninstall unity, reinstall it, and then carefully import the package without the Packages and Sample folders, also Streaming Assets is unecessary without the samples

After a few hours! of research I found out that when I was installing the Wikitude package it somehow corrupted not only the project I was in, but actually all other projects that I upgraded to Unity 2020.1.9f1 or that I started new all got the same error messages.

I found a workaround by quitting the Unity project, uninstalling Unity 2020.1.9f1 and then re-installing Unity 2020.1.9f1. Once I had done that, it was all working fine again, except for the Wikitude project. The errors were gone, but now I needed to add the ARFoundation package and enable 'unsafe code' in the Preferences to get rid of the new errors that appeared. But it was running now.

This all gives me very little confidence to work with Wikitude for now, so I will be switching back to Vuforia.

Login or Signup to post a comment