Start a new topic

Camera won't work on Android Build (Unity) - Is my SDK version too old?

Hello, I have been using Wikitude for a while. As my key is a Free Startup key, I can only use SDK versions released up to a certain point of time, which limited me to version 8.9.0.

So far my own App has been working fine in Unity 2018.4.4f1. Camera works, everything runs fine. But recently due to a change in Google Play terms, I have to make sure the App runs on Android SDK 29, so I updated to Unity 2019.4.9f1.

However, the Camera now will not start up at all on my Android device, only showing a blank white screen in place of the camera feed, despite it running normally inside the Unity Editor. The permissions for the Camera is always asked, therefore should be no problem. There are no errors either in compiling the APK.

My Device is a Samsung Galaxy A20 (SM-A205F) running Android 9.0 (Pie).

Things I have tried: 

  • using the sample App included in the package, still won't work, I have attached some corresponding images. Therefore it does not work on both sample App and my own App.
  • checked and unchecked Multithreaded Rendering in Player settings, as some users have pointed out it affects Camera rendering, I also made sure it uses OpenGLES 3.0 API.
  • putting permission check scripts on my Main Menu and Camera scene,
  • using a custom Android Manifest file I manually created to ask Camera permissions by default
  • as I noticed, an ARCore .aar file is present in the package, so i tried enabling it too, still no change whatsoever.
Things I have not tried:
  • Building an iOS version (Metal Graphics API) since I do not have an iOS device.
Is there a possibility that the issue is caused by a version incompatibility (Unity 2019.4.9f1 and Wikitude SDK 8.9.0)?

If not, what could be a possible solution for this? Thank you so much!

(15.8 KB)
(54.8 KB)

Alright, i took note of a similar problem.

The user pointed out that it's an issue with Unity itself (2019.3). I have tried their solution of using Unity 2019.2 (in my case 2019.2.21f1) and it indeed worked no problem.

Does the Wikitude SDK 8.x have a problem with Unity 2019.3 and upwards? If so, what causes it and what is a possible solution for it? Thank you.


Great that it's working with Unity 2019.2 and thx for sharing the additional forum post. As 2019.3 was released after SDK 8.9, our QA and tests didn't include this version for the 8.9 release tests. You can always find the supported Unity version requirements in our official documentation, which we officially support.

Thx and greetings


Login or Signup to post a comment