Start a new topic
Solved

Flutter integration is not working

Hi,
I followed all the steps listed in your "Setup Guide Flutter", but I only get a black screen, even I copied the arview.dart file from the application example and the same.

All the permissions had been granted.

The example project is runing fine with flutter v.12.13+hotfix.9 in an iPad with 13.3.1.

I ran the app in xcode and I got this log:

2020-05-14 19:02:21.768095-0500 Runner[1388:408782] [VERBOSE-2:platform_view_layer.cc(22)] Trying to embed a platform view but the PrerollContext does not support embedding
2020-05-14 19:02:21.768287-0500 Runner[1388:408782] [VERBOSE-2:platform_view_layer.cc(39)] Trying to embed a platform view but the PaintContext does not support embedding
2020-05-14 19:02:21.800562-0500 Runner[1388:408782] [VERBOSE-2:platform_view_layer.cc(22)] Trying to embed a platform view but the PrerollContext does not support embedding
2020-05-14 19:02:21.800741-0500 Runner[1388:408782] [VERBOSE-2:platform_view_layer.cc(39)] Trying to embed a platform view but the PaintContext does not support embedding
2020-05-14 19:02:21.810514-0500 Runner[1388:408782] [VERBOSE-2:platform_view_layer.cc(22)] Trying to embed a platform view but the PrerollContext does not support embedding
2020-05-14 19:02:21.810693-0500 Runner[1388:408782] [VERBOSE-2:platform_view_layer.cc(39)] Trying to embed a platform view but the PaintContext does not support embedding
2020-05-14 19:02:21.828756-0500 Runner[1388:408782] [VERBOSE-2:platform_view_layer.cc(22)] Trying to embed a platform view but the PrerollContext does not support embedding
2020-05-14 19:02:21.829482-0500 Runner[1388:408782] [VERBOSE-2:platform_view_layer.cc(39)] Trying to embed a platform view but the PaintContext does not support embedding
2020-05-14 19:02:21.844606-0500 Runner[1388:408782] [VERBOSE-2:platform_view_layer.cc(22)] Trying to embed a platform view but the PrerollContext does not support embedding
2020-05-14 19:02:21.845415-0500 Runner[1388:408782] [VERBOSE-2:platform_view_layer.cc(39)] Trying to embed a platform view but the PaintContext does not support embedding
2020-05-14 19:02:21.861523-0500 Runner[1388:408782] [VERBOSE-2:platform_view_layer.cc(22)] Trying to embed a platform view but the PrerollContext does not support embedding
2020-05-14 19:02:21.862896-0500 Runner[1388:408782] [VERBOSE-2:platform_view_layer.cc(39)] Trying to embed a platform view but the PaintContext does not support embedding
2020-05-14 19:02:21.898980-0500 Runner[1388:408782] [VERBOSE-2:platform_view_layer.cc(22)] Trying to embed a platform view but the PrerollContext does not support embedding
2020-05-14 19:02:21.899244-0500 Runner[1388:408782] [VERBOSE-2:platform_view_layer.cc(39)] Trying to embed a platform view but the PaintContext does not support embedding
2020-05-14 19:02:21.909435-0500 Runner[1388:408782] [VERBOSE-2:platform_view_layer.cc(22)] Trying to embed a platform view but the PrerollContext does not support embedding
2020-05-14 19:02:21.909833-0500 Runner[1388:408782] [VERBOSE-2:platform_view_layer.cc(39)] Trying to embed a platform view but the PaintContext does not support embedding
2020-05-14 19:02:22.099754-0500 Runner[1388:408542] [Process] kill() returned unexpected error 1
2020-05-14 19:02:22.103944-0500 Runner[1388:408542] [Process] kill() returned unexpected error 1
2020-05-14 19:02:22.104266-0500 Runner[1388:408542] [Process] kill() returned unexpected error 1
2020-05-14 19:02:22.105208-0500 Runner[1388:408542] [Process] kill() returned unexpected error 1


What I'm missing?
1 Comment

after several hours of searching and frustration, I found the missing part in the guide,


In the info.plist its necesary include the following line:

<key>io.flutter.embedded_views_preview</key>
<true/>



1 person likes this
Login or Signup to post a comment