Start a new topic

Failed to resolve: :wikitudesdk

Hello wikitude

i am facing an issue i couldn't resolve with many tries :( 

I'm receivig this error from ANDROID STUDIO :  

ERROR: Failed to resolve: :wikitudesdk:
Affected Modules: app

 i'm working with:

  • wikitude SDK 8.1 (JS API)
  • Android Studio 3.6.2
  • Gradle plugin version  3.6.0
i migrated from 6.0 to 8.1 and added the needed lines to the code (i think), any suggestions?


Hi Nikola

I solved it. 

i had the Repositories inside BuildScript{} So i removed it out and it worked. I'm working with 8.1 because i had it when i purshased the Startup SDK, I will consider migrating after i publish the app on the Play Store because i need to experiment the tool for a theis
Best regards


Hi Mohamed,


This error message seems to be related to the project setup and build.gradle setup. Please make sure that the build.gradle settings are as described in the documentation (you can also compare your setup with the one of the SDK sample app). As this is more related to the setup of project than to the Wikitude SDK directly, please also check other sources (e.g. stackoverflow) for the error message 'failed to resolve' in combination with libraries.


Note: as version 8.1 was already released in September 2018 and we're currently at SDK version 9, we strongly recommend that you upgrade to the latest version, to get the latest improvements and also ensure comptability with the OS.


Thx and greetings

Nicola

Login or Signup to post a comment