Start a new topic

Build fails on Wikitude basic IOS integration

Hi, I am trying implement basic tutorial   from documentation but my build fails with error 

Ld /Users/julia/Library/Developer/Xcode/DerivedData/wikitest-fkqskpyzyxkxsbfjqenybsnkjlet/Build/Products/Debug-iphoneos/ normal arm64 (in target 'wikitest' from project 'wikitest')
    cd /Users/julia/XcodeProjects/wikitest
    /Applications/ -target arm64-apple-ios9.0 -isysroot /Applications/ -L/Users/julia/Library/Developer/Xcode/DerivedData/wikitest-fkqskpyzyxkxsbfjqenybsnkjlet/Build/Products/Debug-iphoneos -F/Users/julia/Library/Developer/Xcode/DerivedData/wikitest-fkqskpyzyxkxsbfjqenybsnkjlet/Build/Products/Debug-iphoneos -Fwikitest/Frameworks -Fwikitest/Frameworks -filelist /Users/julia/Library/Developer/Xcode/DerivedData/wikitest-fkqskpyzyxkxsbfjqenybsnkjlet/Build/Intermediates.noindex/ -Xlinker -rpath -Xlinker @executable_path/Frameworks -dead_strip -Xlinker -object_path_lto -Xlinker /Users/julia/Library/Developer/Xcode/DerivedData/wikitest-fkqskpyzyxkxsbfjqenybsnkjlet/Build/Intermediates.noindex/ -Xlinker -export_dynamic -Xlinker -no_deduplicate -fembed-bitcode-marker -fobjc-arc -fobjc-link-runtime -framework WikitudeSDK -Xlinker -dependency_info -Xlinker /Users/julia/Library/Developer/Xcode/DerivedData/wikitest-fkqskpyzyxkxsbfjqenybsnkjlet/Build/Intermediates.noindex/ -o /Users/julia/Library/Developer/Xcode/DerivedData/wikitest-fkqskpyzyxkxsbfjqenybsnkjlet/Build/Products/Debug-iphoneos/

ld: warning: ignoring file wikitest/Frameworks/WikitudeSDK.framework/WikitudeSDK, building for iOS-arm64 but attempting to link with file built for unknown-unsupported file format ( 0x76 0x65 0x72 0x73 0x69 0x6F 0x6E 0x20 0x68 0x74 0x74 0x70 0x73 0x3A 0x2F 0x2F )
Undefined symbols for architecture arm64:
  "_OBJC_CLASS_$_WTArchitectView", referenced from:
      objc-class-ref in ViewController.o
ld: symbol(s) not found for architecture arm64
clang: error: linker command failed with exit code 1 (use -v to see invocation)


My environment is

  • Xcode Version 11.4 
  • Wikitude framework 8.1
  • Device iPhone 6 (real device, not emulator)

Initially, I was trying to add React native module

and after all "Not found" issues have been fixed appeared error  

Undefined symbol: _OBJC_CLASS_$_WTArchitectView

After that, I decided to implement a native IOS app to test the framework but still get the same error.


The error indicates, that there seems to be something wrong with the build setup and the architectures. Please ensure that everything is setup for 64 bit architecture. For a reference you can also find further details in iOS forums that might help.

Thx and greetings


Hi Nicola,

well, I tried everything from the beginning. My advice for everyone who faced problem in the build just download SDK and run examples project (folder Examples )

you can check any IDE settings by comparing your project with examples. So I added some run scripts and find additional settings according to example project and make my project build and run normally.


Thx for your feedback. This sounds like the problem is solved for you. Thx for providing the details for other users as well.



Login or Signup to post a comment