Start a new topic

Android unity build not working


So I have a unity project in which I have three scenes. In each I used WikitudeCamera. In one I used ImageTracker and in other two I used ObjectTracker. If I run it in unity with a webcam, it works perfectly. The images and objects get detected and the everything works fine. The project was build on Windows platform. I switched it to Android platform and tested again with webcam, still everything works fine. But when I build and run on Android tablet, my ImageTracker gets detected only for a second and then desapears. I did't change anything while building, should I? I didn't get any errors while building.

I have looked around on the forum trying to find a solution, but so far I haven't found one that works. I am new to Unity and Wikitude.

    Unity 2019.2.14f1
    Device: Samsung Galaxy TabA
    Android version of device: 9
    Platform: Android 9.0

Hi Iva,

Please provide these details:

Does the same also happen with SDK 8.10?

Is this issue only occuring on this specific Android device, so is it only happening on this specific device? 

Is our unchanged Unity SDK sample application working on the Samsung Galaxy TabA --> if it does, what happens if you switch just the .wtc file from the SDK sample app with your own .wtc file --> does the image tracking work then?

Did you debug the code - is the recognition working as expected and then lost or did you find any other behaviour during debugging?

Did you make sure that the target image(s) have a suitable quality for tracking --> can you share the image and a video showing the tracking differences between of the webcam and the Android device?

Thx and greetings


The same things happen with SDK 8.10. I tried only this device because I don't have another Android device. Sample application is working fine, as soon as I switch to my images (my .wtc file) I get this problem. It looks like a problem in image quality but they got 2/3 stars, one of them got 3/3 stars in Wikitude studio. Images are attached to this post. 



Hi Iva,

I just tested the target images and they are working with the SDK sample app (tested on Galaxy S7). Could you please also share a video of the scanning and the behaviour, as I'm not sure if you're referring to the images not working at all or if they are not working well.

Thx and greetings


Login or Signup to post a comment