Start a new topic

Buttons on AR objects don't work

I programmed a unity project with AR image tracking. It works perfectly, two buttons appear on the target and move with the object on the right place, when I move the device. But the buttons didn't recognize a click or a tap on it. Neither in the unity preview nor in the app on my iOS devices.

Maybe someone can anticipate what I'am doing wrong?

Okay, now I have the solution. I only had two sprites with a button component, but now I use a Canvas with world space configuration and I have placed two buttons on it. Now the buttons work when they get pressed or touched. Thank you!


Are you using Unity's UI system in with a World Space configuration? Last time I tried that, it worked fine, so I think it might just be a configuration issue. If you could please send us with a simple reproduction project at, I will gladly have a look to see what might be wrong.

Best regards,


Hi Björn,

Could you please provide more details on your issue?

  • Which version of the SDK are you using?
  • Are you getting any crash log?
  • What device does this happen with (os Version and model)?




I'm using the new Expert Edition SDK (Beta 3) from 12/18/2019. But I had the same problem before.

The log didn't show anything. It seems, that the app doesn't understand, that there is a button on the AR object, which can be clicked. There is no crash, the buttons appear but don't react when getting "pressed".

My devices are an iMac with the latest Unity version (unsuccessfully tried in game view with mouse clicks), an iPod touch with iOS 12.4.1 and an iPad Pro with the latest iOS.

When I use the "normal" canvas to position the buttons, they work perfectly. When they are located in the trackable object, they just appear without function "on click". Maybe I forgot something …

Kind regards

Björn Tiemens

Login or Signup to post a comment