Start a new topic

Vuzix M400 support

Hi,


I'm trying to get the Vuzix examples working on the M400 - but they don't. Is the 400 supported at all? 


For clarification - you mentioned that 9.5 Android JS SDK is showing a black screen  but 8.10 is showing the AR experiences. When you say 'not working', can you please specify what happens - do you get error messages or logoutput, do the images e.g. not get recognized?


Thx and greetings

Nicola


Sorry for the confusing, we are more interested in ArchitectStartupConfiguration.Features.Geo [outdoor].
It seems like both 9.5.0 and 8.10.0 for example 08_PointOfInterest_1_PoiAtLocation is not working in M400.

Hi Jai,


were you able to run the Android SDK on the vuzix glasses. In general we're currently not maintaining our Vuzix SDK, but did you try with our standard Android SDK?


Thx and greetings

Nicola

that's my test in that discussion.


Regular or standard Android SDK v9.5 does not work for Vuzix M400 (included built-in GPS). 

 

I can install and launch, but the screen is black, attached.

Is it because of 


<uses-feature

        android:name="android.hardware.camera"

        android:required="true" />


This class was deprecated in API level 21. We recommend using the new android.hardware.camera2 API for new applications.

I also like to know does the PROFESSIONAL NATIVE API work on Vuzix M400?


What SDK edition can I use based on the devices I want to support and the development platform I work with?

"startupConfiguration": {

                    "camera_position": "front",

                    "camera_resolution": "auto"

                }

in samples.json the above code change also does not work in M400.

Hi Jai,


We didn't test the Android APIs on the Vuzix M400, as we don't officially support this device. So we can't unfortunately provide you with detailed information if the Native API is working on the M400 or what the exact issues of the latest Android JS API are with the M400.


One thing that you can try out is testing using the Android SDK 8.10., which correlates with the last Vuzix SDK release. You can find all older SDK versions here:

https://support.wikitude.com/support/discussions/topics/5000091233


Thx and greetings

Nicola

M300 is Dual-Core Intel x86, definitely, 8.10.0 will not work on M400. we should be using this
https://www.wikitude.com/download-wikitude-sdk-for-android/ for M400, right?

Hi Nicola,


What is the different between 9.5.0 and 8.1.0?
Does 8.1.0 have the Geo feature, for outdoor usage?

Details about all the important changes can be found in the Release Notes in the online documentation


Yes, 8.10 also offers our geoAR feature.


Thx and greetings

Nicola

Hi Nicla,


We tested 8.10.0, not all samples work on M400, particularly 08_PointOfInterest_1_PoiAtLocation not working.

Hi Jai,


did you check the Location handling - you can find details in the documentation under:


https://www.wikitude.com/external/doc/documentation/latest/android/setupguideandroidlocation.html#location


And made sure that the runtime permissions are set as expected - you'll need to ensure that the permission for the location is set.


Thx and greetings

Nicola

Login or Signup to post a comment