Start a new topic
Solved

manifest merger failed - unity + android

I am trying to build a unity android app that includes elements from wikitube and arcore


Strangely wikitude has a minimum api  level 19, whereas arcore has a minimum of 24


I can build the wikitude unity demo when I increase the minimum, however when including the arcore sdk (whether using the google unity package or installing via the unity package manager) I get a manifest merger failed error.


Manifest merger failed : Attribute meta-data#com.google.ar.core.min_apk_version@value value=(190919000) from [:arcore_client:] AndroidManifest.xml:35:13-38


is the a work around for fixing the wikitube minimum sdk?


Hi Matt,


Did you check the following:


In our Setup guide for Unity under 'Export and Xcode Build Settings Changes' for the Export to Android Studio:


Android Studio may complain about minSdk version and targetSdk version being set. Remove the line from the AndroidManifest.xml ( <uses-sdk android:minSdkVersion="19" android:targetSdkVersion="24" />), and re-run gradle.


If this does fix the issue, please let us know.


Thx and greetings

Nicola


Hi Nicola


In my case I am trying to build to an .apk rather than build to an Android Studio project.


If I build to an android studio project I still get the same error in Android Studio. 

Even if I delete the line you suggested.

Manifest merger failed : Attribute meta-data#com.google.ar.core.min_apk_version@value value=(181012000) from [:arcore_client:] AndroidManifest.xml:43:13-38

 is also present at [:core-1.5.0:] AndroidManifest.xml:43:13-38 value=(180815000).

 Suggestion: add 'tools:replace="android:value"' to <meta-data> element at AndroidManifest.xml:41:9-43:41 to override.


Im thinking maybe the problem is being caused by the arcore part rather than wikitude 



Hi,


Can you try simply removing the "core-1.5.0.aar" file in "Assets/Plugins/Android"?


Thank you,

Alexandru


Login or Signup to post a comment