Start a new topic

New View Style (Not Full Screen) & Questions - iOS 13 / SDK 8.9.1

Hi,


I recently updated to Wikitude Cordova SDK 8.9.1 and using an iPhone 11 with iOS 13 installed.


The Wikitude world used to load full screen on previous iOS and SDK versions.


With the new SDK and iOS 13 the world opens up in a sort of InAppBrowser type of view that can be dismissed by swiping down. Also the app is visible behind it on the top.


Is this the standard way the Wikitude world view is now? As a result of switching to WKWebView? Is there any way to get the completely full screen view back? See attached images. One is how it looks loaded. One is me swiping down to close it.


Did anything in the Cordova/JavaScript API change from 8.5 to 8.9.1? As in, do I have to change anything in my code when update from 8.5 to 8.9.1 in order for it to work properly? I didn't see anything in the docs but wanted to make sure there weren't any changes I need to make on my end. Are there?


Thank you!

loaded.png
(4.59 MB)
png

Hi Eric,


Did you check the iOS migration guide already to make sure that general iOS related changes from 8.5 to 8.9.1 were applied?


https://www.wikitude.com/external/doc/documentation/latest/ios/migration.html#migration-notes


If not please check and let us know if the error persist afterwards.


Thx and greetings

Nicola

Hi,


Thank you for the reply. I have viewed the change log.


I do not know if it is an error. I am asking if this view that I mentioned and attached pictures of is how it is supposed to look now.


Is it an error? Or is that how the view is now supposed to look and behave using the specs I mentioned? Also, if this is how it looks now and it is not an error: "is there any way to get the completely full screen view back?"


Please advise if this an error or how it is supposed to look now?


Thanks.

Hi Eric,


The iOS 13 release changed the default style of view controller presentation.


We addressed this in our 8.9 release, setting the presentation style of our controller to full screen in order to keep the same behaviour as before. The iOS source of the plugin you downloaded should contain this line:

self.arViewController.modalPresentationStyle = UIModalPresentationFullScreen;


Please make sure that the plugin you have imported in your project also contains this, or you may still be using an older release.


Otherwise, can you also reproduce your issue in our sample app?



- Damian


1 person likes this

Thank you for the reply.


I will check to see if that line is in the package I downloaded. I believe I am on the latest version of Wikitude considering I added to the project it 6 days ago but there may be some persistence somewhere with an old version. I will double check.


Is there any way to set this from my JavaScript that launches the world? Or is it only in the iOS src file that it is allowed?


I will let you know tonight 1) If what I have downloaded has that line in the src/iOS and 2) If it does and does not work then if I have the same issue on your sample app.

Hi,


Thank you for your support on this. I had the right version downloaded, but an older version was persisting in my platform. I removed the platform the added it back, and this solved my issue.


Now I am seeing a "License Expired" overlay. I sent an email to support and sales inquiring about it. I ordered a startup license on 6/17/2019 and I am trying to upgrade my app to work on iOS13.


Thank you,

Eric

Login or Signup to post a comment