Start a new topic

Application pause tracking issue

When i detect plane and place model, make application pause and launch another app. When i returned to my AR app on wikitude i have tracking issue. We using Intant tracking

mp4

Hi, 


The issue is happening because ARCore is losing tracking when pausing and resuming the application. This doesn't happen all the time, and can be improved by having more lateral movement with the phone, which will make ARCore track better.

Since this cannot be completely eliminated, I would recommend that when this is detected, you ask the user to reinitialize tracking.


Best regards,

Alexandru

Hi Maksim,


We could reproduce the issue and will create a Jira ticket for the next release.


Thanks and greetings,


Aitor Font.

Unity 2019.1.12, wikitude plugin 8.9.0, device pocophone f1 android 9(problem also reproduce on samsung a30). We using simple instant tracking from examples. I didn`t upgrade plugin. Steps for reproduce you can see in video in statr message. I build samples, and have same issue(almost) in my case model doesnt dissapera. In samples - model dissapeared. Video below

mp4

Hi,


As mentioned in the details, when you create a post, please provide the following details:


  • Which version of the SDK are you using and are you working with the JS API or the Native API?
  • Are you using any of our Extensions or SDK for Smartglasses (Cordova, Xamarin, Unity)? If yes, which extension are you using?
  • If you work with Unity, what Unity version are you using?
  • If you work with Cordova, what Cordova version are you using?
  • If you work with Xamarin, what Xamarin version are you using?
  • What device does this happen with (model details and OS version)?
  • Is this happening with the sample app or in your own app? If it happens with your own app, does the sample app work on your device?
  • Send steps to reproduce the issue and include the target images.
  • In case you upgraded the SDK version and the issue happens since the update, did you make sure to check the migration guide to see if something changed?
  • Did you make sure to follow the documentation and the setup guide?


Thx and greetings

Nicola

Login or Signup to post a comment