Start a new topic

No AR in Playstore


We are working on a Project with the Imagetracking system from Wikitude, We have some Problems with the published Version on Playstore.

And some Xcode errors on iOS Version.



Unity: 2018.4.1f
Wikitude: 8.7
Target Low api: 6.0 ( Marshmellow )



The AR in the local APK is working perfectly, once published the AR is not responsive at all.


Here you find the Local Version and the Tracking Markers:

and the Store Version:




At the archiving step in Xcode we get 100 Errors:

Undefined symbol: _UnityWikitudeBindigs_....


We tried it with some different SDKs...with the 8.2 everything works  good.




Hi Norbert,

Did you make sure to follow the migration notes for the Unity SDK. Do you have the same issues with the latest SDK 8.9 and also when building the SDK sample app for 8.7 or 8.9?

Thx and greetings


Hello Nicola,

Yes I have read the guidelines ( just 3 o 4 lines ) and followed them.
But AR and Image tracking isnt working in PLAY STORE ( It does only
in Editor and Web cam or Internal phone Build )
Version 8.9
Unity 2018.4

Any suggestion ?

Best regards



I tried the version on the Play Store and it seems to be working. Did you manage to fix the issue?

Best regards,


Hi Alexandre,
Sorry the late response.

Yes we were able to solve the problem.
It was thanks to try and error, until we realize that on local ( unsplitted APK ) was working well.

Solution was
We published the APK not splitting binaries, we did a big AAB file.
Instead having APK + OBB, we had> .AAB file ( large one )

I think it was to do with the internal compiler and references.

Thanks for the assistance,
Best regards


Login or Signup to post a comment