Start a new topic

IPA Processing failed.

Hi.


When I tried to Archive -> Distribute Ad Hoc with Xcode 11 and iOS 13 the IPA processing failed. I already use the new SDK 8.9.1 for iOS, where one of the releases are:

  • Implemented support for iOS 13

If I remove the SDK and implementation of Wikitude from my project and I do the Archive -> Distribute Ad Hoc everything goes well.

The description of the problem is the next one:


2019-10-01 21:17:57 +0000  warning: Configuration issue: platform iPhoneSimulator.platform doesn't have any non-simulator SDKs; ignoring it

2019-10-01 21:17:57 +0000  Scanning IPA...

2019-10-01 21:18:01 +0000  Assertion failed: Expected 2 archs in otool output:

/var/folders/53/d7vqmk294kd6jg2n9t4z7l_c0000gn/T/IDEDistributionOptionThinning.~~~Z8uLjw/Payload/Demo.app/Frameworks/WikitudeSDK.framework/WikitudeSDK:


I hope you can help me with this issue.


Regards.

1 Comment

Hi Beto,


I could not reproduce this issue with our example app in the latest Xcode version.


Which app thinning option are you using when exporting the Ad Hoc .ipa?


Did this just start happening when exporting it in Xcode 11? Or have you ever had an issue like this with a previous Xcode version?


Do you also have any issues when building and running the app on a device? Or is only the .ipa export that is causing problems?


I would suggest making sure that the build settings in your project are only targeting 64 bit architectures, as we do in our example app. Also, check that our framework is embedded with the option "Embed & Sign" in the general tab of your target.


If you are still running into the same issue, please answer the previous questions and provide a sample project if you will, so we can keep looking into this issue.



- Damian

Login or Signup to post a comment