Start a new topic

IPA Processing failed.


When I tried to Archive -> Distribute Ad Hoc with Xcode 11 and iOS 13 the IPA processing failed. I already use the new SDK 8.9.1 for iOS, where one of the releases are:

  • Implemented support for iOS 13

If I remove the SDK and implementation of Wikitude from my project and I do the Archive -> Distribute Ad Hoc everything goes well.

The description of the problem is the next one:

2019-10-01 21:17:57 +0000  warning: Configuration issue: platform iPhoneSimulator.platform doesn't have any non-simulator SDKs; ignoring it

2019-10-01 21:17:57 +0000  Scanning IPA...

2019-10-01 21:18:01 +0000  Assertion failed: Expected 2 archs in otool output:


I hope you can help me with this issue.


2 people have this problem


I am facing the same problem. Did someone already find a solution for this?



1 person likes this

Hi Beto,

I could not reproduce this issue with our example app in the latest Xcode version.

Which app thinning option are you using when exporting the Ad Hoc .ipa?

Did this just start happening when exporting it in Xcode 11? Or have you ever had an issue like this with a previous Xcode version?

Do you also have any issues when building and running the app on a device? Or is only the .ipa export that is causing problems?

I would suggest making sure that the build settings in your project are only targeting 64 bit architectures, as we do in our example app. Also, check that our framework is embedded with the option "Embed & Sign" in the general tab of your target.

If you are still running into the same issue, please answer the previous questions and provide a sample project if you will, so we can keep looking into this issue.

- Damian


I'm having the same problem when using new Xcode 12 Golden Master. it worked with Xcode 11.

I'm using Wikitude SDK 8.1.0 version in iOS, and the following run script seems to be causing the issue:


Could you please confirm if any change needs to be done to be able to archive the project?

Thank you very much,

Kind regards,

Hi again,

It seems that the folder that previous commented run script specified is now wrong, as I can see the following error:

/Users/mobile/Library/Developer/Xcode/DerivedData/XXXhiqutykoifxyjpehcadnwjdaeebc/XXX/Intermediates.noindex/ArchiveIntermediates/XXX/BuildProductsPath/Release-iphoneos/ line 74: /Applications/Xcode: No such file or directory

I changed my app name by XXX in this extract

Please tell if any change should be done to be able to archive apps with your framework with the new XCode12 GM

Thank you very much,

Kind regards,


I also face this problem. When I set wikitude framework "Embad & Sign" General section & try to create IPA & also try to upload build showing some error. please check the attachment.

If I set wikitude "Do not embed" General section then no problem occured but app crashed after showing luncher screen & showing message that "wikitude is not running"

I cant select app thinning option  when exporting the Ad Hoc .ipa . the error message is showing earlier.

I face this issue with latest xcode (11.3) I am not tried to uplaod build with old xcode

With out wikitude frame work there is no problem occured in iphone & also emulator.

Please give the solution.

Thank you

Login or Signup to post a comment