Start a new topic

Google Play Console Upload Error with SDK

When Upload app,


This release does not meet the Google Play 64-bit requirements.  The following APK or App Bundle is available for 64-bit devices, but currently only has the following 32-bit native code: One  Include 64-bit and 32-bit native code in your app. Use the Android App Bundle publishing format to automatically ensure that each device architecture only receives the native code it needs. This will reduce the overall size of your app.


plz help!


Hi,


You can find details on our 64bit support here:


https://support.wikitude.com/support/discussions/topics/5000091127


I hope this helps. Should you need anything further, let us know.


Thx and greetings

Nicola

There is no x86_64 lib in apk,


https://developer.android.com/distribute/best-practices/develop/64-bit


Google mentioned to upload there must be 4 libs in apk.


but there only 3 libs in apk.

screen.png
(234 KB)

Hi,


Google mentioned that it isn't required to support every 64-bit architecture, but for each native 32-bit architecture you support you must include the corresponding 64-bit architecture.


As we mentioned here: https://www.wikitude.com/blog-2019-sdk-clean-up/, we are not supporting the x86 architecture anymore, so i will look at the library generation to see why is this x86 folder being created.


Regards,


Aitor.

Login or Signup to post a comment