Start a new topic

Video not streaming when target tracked on certain Android devices. Shows blank white quad.

Hi there, I am new to Unity and C# scripting. I have created an application with 2 image targets. Both image targets should load a video when being tracked by the Wikitude camera. However, the second video does not play on random Android devices and works other Android devices. 


Video played on: Huawei P9 Lite and Samsung J2

Did not play on: Huawei P20 Lite and Samsung S8

First Image Target:

1. Video is stored in the Unity Package locally. (See Attached Image)

2. Video plays within a Quad 3D Object from Unity

3. When the image target is tracked, the video plays perfectly.


Second Image Target:

1. Video is stored online at this URL http://www.ujar.co.za/ar-videos/UJ_Library_Edit_v1.3.mp4

2. When the image target is tracked, the target is detected and the plain white 3D Quad loads, but the video fails to stream on certain devices.



Please see the included video of Target 1 and 2 being tracked on an Android device.


Kindly Advise

Thanks

mp4

Hi, 


I'm not sure if this is a problem with our SDK, or with Unity's video player. Have you tried to play the video in an empty scene, without any kind of Wikitude GameObjects? 

To emulate the behaviour as closely as possible, I would create an empty scene, add two buttons, one for each video, and when one of them is pressed, instantiate the appropriate video prefab and place it in front of the camera.

Please let us know what the behaviour is in this scenario.


Thank you,

Alexandru

Hi,


Please provide the following details:

  • Which version of the SDK are you using?
  • What Unity version are you using?
  • Is this happening with the sample app or in your own app? If it happens with your own app, Does the sample app work on your device, if you just change the video and load it from the url?


Thx and greetings

Nicola


Hi Nicola,


  • How do I check the SDK version of Wikitude? (The SDK was included as part of an online Tutorial, there is a possibility it could be old.
  • Unity version is 2018.3.11 f1
  • After building the Application, I have installed the APK on my personal phone (Huawei P9 Lite), and both image targets & videos work. The video size is under 8mb. Kindly refer to the attached video showing both working. (Ignore the lag, it only happens when the phone is recording the screen.)  

Just trying to figure out why the video wouldn't stream on some Android devices.

Regards
Moe

mp4

Hi,


I have installed the latest version of Unity2019.1.11f1 along with the latest Wikitude SDK 8.6.0 

Started a brand new project and rebuilt the app. Still has the same problem on the same devices. 


It works on Unity Editor as well when I test before building the APK.


Hope you can help.


Thanks

Moe


Login or Signup to post a comment