Start a new topic

Request POI data from WebService in IOS

When i try to call a specific API from my IOS wikitude application with javascript in order to get POI data, i get response {"readyState": 0, "responseText":"","status":0,"statusText":"error"}. This API works perfectly in my android device with wikitude and it returns a json object. Every API works in my IOS wikitude application except this specific API. There is a problem between UIWebView of IOS and this API. How can i solve this issue?

Hi Wikitude Support Team,

I'm using the javascript SDK for iOS in order to use the Points of Interest for my application.

I'm using XCode for iOS developing, the latest version is 10.2.

The device is iPad 6th generation with 12.3.1 iOS.

Your sample app works in my device but when i try to set my API and call it from the javascript it does not allow me. I also tried to create a new project and call the api with swift for test reason and it worked. My API is

For some reason the javascript in iOS don't allow me to call my API and i have no idea why.

I tried to call other API and every other API works.

The API works fine in android because i created this project in android with android javascript sdk and it works perfectly.

Thanks in advance

Hi George,

Could you please provide the following details:

  • Which version of the SDK are you using?
  • Are you using any of our Extensions (Cordova, Xamarin,..)? If yes, which version are you using?
  • What Cordova version are you using?
  • What Xamarin version are you using?
  • What Xcode version are you using?
  • What device does this happen with (model details and OS version)?
  • Is this happening with the sample app or in your own app? If it happens with your own app, Does the sample app work on your device if you just change the url to the Webservice?
  • Please share the url to the Webservice and any additional details needed to make the call to the service on an iOS device

Thx and greetings


Hi George,

have you tried the corresponding sample in our sample app? I'd be interested to know whether that works on your particular device or not.

- Daniel

Login or Signup to post a comment