Start a new topic

Camera issues in editor on Windows 10

With the 8.3.0 SDK (and perhaps the previous SDK) the camera view can sometimes be distorted within the editor on Windows 10 when running in Unity 2018.2 and Unity 2018.3, but not in Unity 2018.1. And not on OS X. And we have seen this issue only on 2 of 4 Windows 10 computers. We have tested with embedded cameras, external web cams, and remote camera using the Unity Remote 5 Android app. Each of those cameras displays a different incorrect scaling and does not cover the full screen.


I have attached an example image of the video within the editor from a particular Windows 10 machine. The scaling of the image is wrong and there are black borders typically on the right side and top of the screen. We have seen reports of black or missing video in this forum and we are wondering if we are seeing a variation of that.


For now we will continue to use Unity 2018.1 as we haven't experienced these issues with 2018.1.

image.png
(135 KB)

Hi,


Thank you for posting the logs. The values sees right to me and are similar to what I'm getting on my devices, when running with this aspect ratio. When these logs were printed, was the camera still displayed with the black borders?


The DLL with the additional is compatible with Wikitude SDK 8.5. I tried it again with a new project downloaded from our website and with Unity 2019.1. I also enabled ".NET 4.x Equivalent" and it still worked for me. Perhaps the project you tried it on is using an older version of the SDK?


Also, thank you for reporting the issue with Plugin - Advanced Custom Camera scene. I can reproduce it and will fix the tiling as soon as possible. When running this scene with an aspect ratio > 1, does the camera look correct, without black borders? Does the same aspect ratio then not work properly the regular samples?

In general, I would not recommend using Input Plugins to work around this issue, unless you're only planning on running in the editor. In the final build there will be additional overhead caused by copying the camera frame from Unity, which can cause some performance degradation.


Best regards,

Alexandru

Hello again Alexandru

To follow up, yes the black border appears when using this DLL with the additional debug.

I have double checked and created a new unity 2019.1 with the 8.5 SDK, it still has the offset with the black border. I checked with both .NET 4.x and .NET3.5 (just in case). I adjusted both the Scripting runtime AND api compatibility. These all had the offset. This is all on a microsoft surface book 2.

We will only really use the custom camera for editor, yes. The main issue we're having again is that we need to be able to accurately line up elements to its real world tracker, so having this offset bug in editor is rather troublesome.

I will post more information as i continue debugging. Thank you again.

Hi, 


I'm not sure if this will work with your workflow, but maybe you can use the preview in the Scene view to align the content to the target, as described in the documentation, at least until we find a solution for the issue.


Best regards,

Alexandru

Attached are pictures of strange behavior regarding the offset and black border. Depending on where the game window is, the center of the "background image" is offset according to the game window's location. I can't seem to find a correlation between the two positions, but this information may be helpful to you.

We experience this on two of our computers.

The third computer has the same offset no matter where the game window is.
It is quite strange that the behavior is not consistent between all computers. All computers are using unity 2019.1.6 with the 8.5sdk and provided DLL


Hi, 


I was finally able to reproduce the issue. It seems to be caused by having a scaling value in the Windows Display settings that is larger than 100%. I guess Unity changed how it handled this on Windows and somehow affected our rendering.

We'll try to include a fix for this in the next update, but until then, please try to run without scaling, at least to verify that this is the source of the bug for you as well.


Thank you,

Alexandru

Hi !


I don't how you found this but thanks a lot for resolving my issue. It's actually good and i can keep going finally.


(I changed from 125% display to 100 % in Windows Settings ).


Alexandru!
I can confirm that this is THE issue!

Thank you for helping us find out the solution. For now we will use 100% scaling on our windows devices. I guess this is a good bug to find for the wikitude dev team as well. Thank you for your help!

I will wait eagerly for a new patch note with this scaling fix.

Norman and Tactic LLC

Login or Signup to post a comment