Start a new topic

TargetCollectionResource is never loaded

I am using Wikitude 8.1 with Cordova 8.x. I have the default Cordova-setup with only the Wikitude plugin installed. I tried to run the Example from githu, but when I try it on my Android 7 phone, it only shows Loading.
I was searching for a while now and found out that in the imageontarget.js this.targetCollectionResource is never loaded, which is why the imageTracker  also never calls its onTargetsLoaded callback. When I debug it with chome debugger I can see that the loading property of the targetCollectionResource throws an error: 

"TypeError: AR.i.getBridgeObject(...).loading is not a function

at Object.isLoading (file:///android_asset/www/js/ade.js:1:456231) at Object.__executeFunctionByName (file:///android_asset/www/js/ade.js:1:346943) at Object.callSync (file:///android_asset/www/js/ade.js:1:346674) at c.loading (file:///android_asset/www/js/ade.js:1:209970) at c.invokeGetter (<anonymous>:2:14) at Object.createOverlaysFn [as createOverlays] (file:///android_asset/www/js/imageontarget.js:25:24) at Object.initFn [as init] (file:///android_asset/www/js/imageontarget.js:4:14) at file:///android_asset/www/js/imageontarget.js:78:7

Please give me a hint what I am doing wrong

Hi Jennifer,

I recommend you do not use the samples from GitHub, but download the regular JavaScript SDK package from our website and use the samples therefrom. I can't vouch for the GitHub sample being updated correctly. Could you try that and report back to me whether that changes anything?

- Daniel

Hi Daniel, 
Thank you for your hint.
I took the samples from the sdk and run the installation script instead of just copying the code I needed. 

First the script wouldn't run on windows, but with using a Git bash it worked fine. After running the update script the example worked too and I was also able to edit it and got it still working.
Unfortunatly I couldn't find the difference to the Github code, so I'm not able to tell where the problem were. But I think it might be some configuration. 

But anyway, now it works for me, so thank you!


Maybe you could update the documentation here:


Hi Jennifer,

glad to hear it's working now. Do you happen to have the error output for the regular windows command line (without Git bash)? I'd be interested to see what the problem is there.

- Daniel

Login or Signup to post a comment