Start a new topic

Textures are not working, and Wikitude crashes when importing


I'm new with Wikitude etc augmented reality stuff, but have done quite much 3D-visualizing throughout years (though my skills are not very updated). 

I'm using 3Ds Max 2017 to export its scene into a fbx-file, and tried maybe all combinations of export to try to make it open in Wikitude, but it crashes, shuts Wikitude down in seconds. I have Windows 10. 

BUT, my friend, who has a Mac OS, can open at least some of these files, but he doesn't see the textures, just black silhouettes, expect when there's no bitmap in some object he seems to see its color (that crucifix on the top of the church). 

And I can open some example files that I found from 3D Max's folders, but also they are just silhouettes without textures. 

See the attached FBX- ja MAX-files if they could help... I did several exporting variations with the help of that Wikitude user manual... 

My scene has just some 700 vertexes, so it should function easily with any phone... 

I wonder what all procedures might be needed to consider to make this work in any mobile phones' augmented reality applications...



I just tried to open the .fbx files in the .fbx viewer and also there the textures are missing. So best is make sure that the model already has correct textures with the .fbx viewer and follow the good practices on how to work with 3D models (e.g. use power 2 for textures,..).

If the model looks correct in the .fbx viewer and still has issues with the Wikitude Encoder, please let us know.

Thx and greetings


Hi, thanks for replying! 
It works nearly perfectly in the FBX Review software (which you meant with ".FBX Viewer"?) ! (Just some small geometry distortions, which r not so crucial for now.)

But doesnt get imported into Wikitude... 

I have, as far as I know and understand, checked the good practices from that User manual of yours: 
My textures are simple bitmaps, png-files with power 2 (eg 1024x1024pix, and 2048x2048pix), textures are in the same folder as my scene file (though where was this asked in the export settings??), I have only one light (spot with directional light as u can see from one of my file names). 

There are no warnings in export. And indeed my Wikitude crashes without warning with my files in import (I have Windows 10), unlike my friend's (Mac) and yours (Mac too?)... 

I'm so clueless..:<

Hi, so this still doesn't work, even though it looks (nearly completely) correct in FBX Review. 
I'd be Very grateful if this would get functioning...! Big work projects may depend on it...


This forum post is now assigned to our technical team, as their knowledge is needed and they will answer it directly in the post once they are on it to answer forum posts. 

Please stay tuned.

Thx and greetings



would it be possible to have the textures and the texture paths you set for the FBX?

The Windows encoder crashing is an issue we've had for quite a while, and, I'm afraid one that we won't fix very soon either. Luckily, there's a very easy workaround. You can simply bypass the encoder application and use the command line encoder directly.

In the 3D encoder application files, under tools/win/ you will find the gameplay-encoder.exe binary which does the actual encoding. I'm pretty sure it will not be affected by this crash.

It should be as simple as running the executable on the command line and supplying input FBX path and output WT3 path. For some options, running it with -h should give a decent explanation of what is available.

- Daniel

Login or Signup to post a comment