Start a new topic

Error Loading Targets: The associated image target collection failed to load

Hey,

i can't get image tracking to work anymore in unity. 

When trying the Sample Scenes ("Image Tracking - Simple" or "Image Tracking - Runtime Tracker"), i get the following Error Messages in the console (coming from "OnErrorLoadingTargets") :

Error loading targets!

        Error Code: 6002

        Error Domain: com.wikitude.image_tracker

        Error Message: The associated image target collection failed extraction

    Underlying Error: 

        Error Code: 1001

        Error Domain: com.wikitude.computer_vision_interface

        Error Message: Unable to create dataset from given target collection resource 'C:/Users/myUserName/Documents/myUnityProject/Assets/StreamingAssets/car.wtc'.


I don't know how to debug this further. Unfortunately, i can't share my unity project. 

I am on Version 8.1 and use Unity 2017.4.12f1.

Thank you in advance!


Hey Nicola,

thank you for your answer. The problem disappeared and i am pretty sure that it was fixed after i changed my projects' product name (Build Settings) to the same that is used in the Wikitude Unity Example Project. (i used the example project license key in the wikitude camera project). 

So maybe a bug related to licensing?

Anyway, this can be closed. Thank you!

Hi,


So if you change the product name to the same as the ones used in the Wikitude sample project it works? Is this only related to the name or e.g. the bundle id?


Thx and greetings

Nicola

Hi,

yes, i only changed to product name.
I didn't build the app to a device. I had this problem only in the unity editor ("regular" Windows Build target (not UWP)), so i guess there is no bundle id?

Ah, you're referring to Win. Does the same happen if you build with UWP build target and only when you build for the editor and not the device? In general the bundle id = package name for UWP. You can find details here:


www.wikitude.com/external/doc/SDKTechInfos.pdf


Greetings

Nicola


Hi Christian,


Does this happen within the sample app? Does it work with the latest Unity SDK version 8.2?


If the error is not reproducable within the sample app, can you create a simple demo project, that you can share and which allows us to reproduce the error?


Thx and greetings

Nicola

Login or Signup to post a comment