Start a new topic

Instant tracker "unable to save current instant target" after load

Hello Everybody!


I am using the Wikitude Native API for Android in the latest version: 8.2.0.


I am trying to createa a activity, whitch stores and loads instant targets. I have two buttons. One to store and load the instant target and one to reset the instant tracker. 


My problem is, after i save and load an instant target i can't store a new target. Every time i get this error message: code: 1003, domain: "com.wikitude.computer_vision_interface", message: "Unable to save current instant target."


I think i have to delete something or to instantiate a new object. When I reload the activity / view everything workes fine . I have tried different things, but nothing worked.




savemethod.JPG
(92.5 KB)

Alright, I'll need to try this myself and see what happens internally. I'll get back to you as soon as I've found the time to do so.


- Daniel

Hello Daniel,


Yes, you understand it right. After the loading I want to save a new target not the same twice.

Yes i tried the same path, as well as a different path. Both variants delivered the same error.


As you can see here, when i reset the InstantTracker I create a new file. The file exists in the directory but it's empty.


image


And the save method:

image


Sorry for the small pictures in the first post.


Nice regards Alex

Hi Alex,



I've had a look at the code and there seems to me to be only two conditions upon which this error is returned. Either there is something wrong with the file you're trying to write to (std::ofsteam::good returns false) or the target you are trying to save does not have any tracking points.


Do I understand correctly, that you are starting instant tracking, storing the target, loading the target and afterwards storing the target again? Are you using the same path again for storing the second target?



- Daniel


Login or Signup to post a comment