Start a new topic

Wikitude paid license not taken into account?

Hi,


since a couple of months I've been working on a project where I inherited the code-base from other devs. It's an ionic/cordova app where the wikitudePlugin is used.

I am told we have paid licenses for our dev/acc/prd apps, when creating a build I made sure the existing files were updated with the sdk key (according to this doc: https://www.wikitude.com/external/doc/documentation/latest/phonegap/triallicense.html).

before building an android app:

/plugins/com.wikitude.phonegap.WikitudePlugin/www/WikitudePlugin.js

/platforms/android/platform_www/plugins/com.wikitude.phonegap.WikitudePlugin/www/WikitudePlugin.js


In the constructor of our AR I'm logging the sdk key, which returns the correct value while running on a real device. The plugin seems to work like expected.

But.... we're still seeing the Wikitude splash-screen on startup and the "powered by Wikitude" logo on the bottom left.
I don't see any errors occurring in the logs, nor do I see a "TRIAL" or "LICENSE KEY MISSING" watermark across the AR view.


Any idea what might be missing? and/or how to validate our license keys? and/or how to validate to which app identifier the keys are bound to?


Thanks in advance,

Tom


Hi Tom,


The trial watermark might appear if the license key was not copied into the correct place in the app and exactly as provided, the app id of the app is not exactly the same as the one that was used when generating the key, the app is not cleaned before building. 


Because you are working with Cordova, please make sure that you add the license key in all four WikitudePlugin.js files since Cordova is duplicating this particular file.


Thanks,

Eva

Hi Eva,


Thanks for responding.


Just to clarify my previous message, and after some extra tests...



When I build our DEV app, with a Trial license (which is in my (new) My Account)), with "type=SDK_TRIAL" and "Platforms & App IDs=any: any":

 - I see the trial license key logged to the console with: console.log(this.wikitudePlugin._sdkKey);

 - I see the AR with "powered by.." and TRIAL watermark


When I build our DEV app, with what (I am told) should be our PROD paid license:

 - I see the PROD license key logged to the console with: console.log(this.wikitudePlugin._sdkKey);

 - I see an error in the log: E/ArchitectView: License key is missing or invalid. Please add a valid license key to your app.

 - I see the AR with "powered by.." and LICENSE KEY MISSING watermark and an error-alert


When I build our DEV app, with what (I am told) should be our DEV paid license:

 - I see the DEV license key logged to the console with: console.log(this.wikitudePlugin._sdkKey);

 - I see the AR with "powered by.." watermark. As I said in the previous post, no other watermark across the screen.



So I'm pretty sure the app is built correctly, the license is in the correct WikitudePlugin.js files and the licenses I provide are being used.


I'm just not sure whether there is a mismatch between the license and app-id, hence my question whether there was a way to figure this out.



KR

Tom

DEV.jpg
(2.86 MB)
PROD.jpg
(1.76 MB)
TRIAL.jpg
(1.87 MB)

Hi Tom,


If I am not mistaken, you have purchased an SDK PRO 3D license. You can log in here (https://www.wikitude.com/licenses/) with the email you used to make the purchase and see the app id you have provided as well as the license key. I cannot post the email here as this is sensitive data.


In addition, since you have purchased a subscription, you can reach out to support@wikitude.com and create a support ticket. There, we can share with you the app id, the email you used to make the purchase and the license key.


Thanks,

Eva

Login or Signup to post a comment