Start a new topic

Continuos Image Recognition not scanning with Input Plugin on Android Javascript API

When I try to use the Continuous Image Recognition with a Input plugin the onRecognized method is never invoked. Steps to reproduce:


1) In the examples for Android Javascript API go to samples.json and change the line 659 to 04_CloudRecognition_2_ContinuousImageRecognition so that the Simple Input Plugin is loading the the cloud recognition example

2) Test it on device - the recognition should not function

3) Alternatively test the CloudRecognition > ContinuousImageRecognition, this still functions without problems.


A few notes: 

I am using the newer Camera 2 API for my testing.


I have already implemented the same combination of cloud recognition and input plugin on iOS and everything works as expected so I assume this is not an intended behaviour.


Thanks


Hi,


Please provide further details:


- Which version of the SDK are you using?
- what device does this happen with - is this happening with all test devices you test with?
- is this happening with the sample app or in your own app? If it happens with your own app, does the sample app work on your device.
- Send the complete AR experience as zip file (incl. the html, css, js files, assets, target images)

Greetings

Nicola

Hello,


- using SDK version WikitudeSDK_Android_8-2-0_2018-11-13_11-32-16

- the device is tablet Huawei bg2-w09 but the same thing happens in the emulator

- this is happening in the sdk examples , once I modify them (but of course also in my own app)

- I would send the modified sdk suite, but it's too big. Please just follow my setup instruction from my first post.


Thanks


Hi Thomas, 


We'd only the need the AR experience, that would we could integrate on our end to the sample app. Alternatively you can also provide us with the exact code changes (I assume it's just some lines of code we need to switch).


Greetings

Nicola

The AR experience is the 04_CloudRecognition_2_ContinuousImageRecognition example located under assets/04_CloudRecognition_2_ContinuousImageRecognition. I haven't changed any lines of code in there.


The core of the issue is with combining the Simple Input Plugin with the 04_CloudRecognition_2_ContinuousImageRecognition. 


For you to test this out, you only need to change the samples.json file in order to run the 04_CloudRecognition_2_ContinuousImageRecognition with the Simple Input Plugin.


Is that more clear?

Hi,


No not quite - please provide us with your samples.json to make sure we have exactly the same setup.


Thx and greetings

Nicola

Ok, here it is - the change is on the line 659.


After you change the file you need to run the Simple Input Plugin example.


Thanks

json
(24.1 KB)

So there is nothing else you changed - not sure why you change the reference in the samples.json. This file is only used for the list overview items to start the correct sample - so I still don't quite understand what you're trying to achive, it sounds you simply are switching list items.


Can you please explain in more detail what you're trying to achive?


Greetings

Nicola

I am trying to implement an Input Plugin to allow a pinch to zoom functionality while running Continuous Image Recognition.


The problem is when you start running the Simple Input Plugin together with the Continuous Image Recognition the recognition will never start.


That's why the easiest way for you to test this is to change the samples.json and instead of the running the 13_PluginsAPI_3_SimpleInputPlugin with the Surfer Image Tracking example is to run the 04_CloudRecognition_2_ContinuousImageRecognition instead.

Thanks

Good morning Tomas,



I've just tried what you describe and could reproduce it on one of our devices. My initial guess was that this could be related to a peculiar camera frame data layout as is so often the case with the Camera2. It seems, however, that the cause lies elsewhere. Running on the LG Nexus 5X worked fine, while running on the LG Nexus 5 did not. These devices have the same frame data layout. I also tried this with our most current develop branches and found the issue to still be present. So it seems this requires internal fixing.


I will create an internal bug report and run this past our Android developer when he is on site again.


Meanwhile: have you tried using the old camera instead? If so, did that work for your particular device?



- Daniel


1 person likes this

Hello Daniel,

I just tried to switch to the old camera on my device (Huawei bg2-w09) and the issue is still present. Just a reminder - the issue is occurring also on the emulator.


Let me know if you need any more help

Thanks


Tomas

Login or Signup to post a comment