Start a new topic

Camera feed not working on Android devices

I am using Unity 2018.3.0f1 and Wikitude sdk version 8.2

The camera feed is missing when i compile to Android using instant tracking. The feed goes pitch black

i have already tried turning on and off the multithreaded rendering, I don't have metal as a Graphic API. I tried with a personal proyect and with the example proyect with the same results.


On which device is this problem happening? Have you tried other devices as well? 

Can you try to set the Graphics API to OpenGLES3, if that is supported by your device?

Are there any error messages printed in logcat?

Thank you,


I found out what was going, I didn't have IL2CPP selected (this solved a problem that was destroying the InstantTracker leaving Wikitude unable to initialize). And the reason i couldn't see the camera feed was because you only ask for permisions on the Awake function of the menu scene. Because of the fact that i was testing Instant tracking i was always starting on the Instant Tracking scene therefore never being asked for camera permissions.

Login or Signup to post a comment