Start a new topic

Camera rendering flickering on iPad iOS 12

Unity Version: 2018.2.17f1

Wikitude vers: 8.2.0 (Trial or Demo license)

Device: iPad 6° gen (3 devices)

BUILD O.S.: iOS 12.0.1, iOS 12.1, iOS 12.1.1


Issue: Camera rendering is flickering in "Instant Tracking - Simple" example scene as attachments

-----------------------------------------------------------------------------------------------------------------

Image-2.jpg
(877 KB)
Image-1.jpg
(818 KB)

3 people have this problem

 Okay, sorry for the delay.


Built from the native samples, no tampering at all we sadly still have the same issue as shown below.


Just the same as Unity, Smart Tracking seems to be the issue. With the plane detection sample (which presumably doesn't use Smart Tracking) working fine.


Let me know if I can be of any more help!



1 person likes this

Hi, 


"Auto Graphics API" should be fine. Do you get the same issue when running the example project from the download package directly?

Have you tried running on other iOS devices? Do you get the same problem?


Thank you,

Alexandru

I created new project just to test again by the following steps:

- New project in Unity 2018.3.0f2

- downloaded and imported Wikitude SDK Wikitude_Unity_8-2-0_8-2-0_2018_11_13_15_31_30.zip from Wikitude website

- switched to iOS platform

- opened "Instant Tracking - Simple" example scene

- insert Wikitude Trial license

- build for iOS (player settings: Auto Graphics API: on, Set Camera Usage description, Architecture: Universal, iOS minimum:9.0, WikitudeSDK.framework added to embedded binaries)

- open XCode 10.1, signed with our app dev profile and Run on iPad 6° gen  (iOS 12.1.1)


See attachment for Result. It's intended in 3 different devices (iPad 6°gen iOS 12). 

Only iPhone 6S and sup or iPad Pro works correctly.


Image-1.jpg
(806 KB)

Hi Alexandru,


No luck, but different behaviours.

I tested Unity project inside the folder "\Examples\WikitudeUnityExample".

- Scene: Instant Tracking - Simple.unity

- Unity version: 2018.3.0f2

- Platform iOS



RESULTS:


A) In Unity Editor running the scene get the following errors in the Console:

 

1) first error

Error initializing tracker!
        Error Code: 1004
        Error Domain: comm.wikitude.tracker_manager
        Error Message: Unable to create InstantTracker
    Underlying Error: 
        Error Code: 2001
        Error Domain: com.wikitude.license
        Error Message: The feature usage 'tracking_3d' is not granted with the given license key
    Underlying Error: 
        Error Code: 1010
        Error Domain: com.wikitude.licensing
        Error Message: Platform ["ios","android","uwp"] is not licensed.

  2) no ending error

Could not check if tracking can be started because the InstantTracker doesn't exist!
UnityEngine.Debug:LogError(Object)
Wikitude.TrackerManager:DebugLogError(String)
Wikitude.WindowsEditorWikitudeBridge:UnityWikitudeBindings_CanStartTracking()
Wikitude.WindowsEditorWikitudeBridge:Wikitude.IWikitudeBridge.CanStartTracking()
Wikitude.InstantTracker:CanStartTracking()
InstantTrackingController:Update() (at Assets/Wikitude/Samples/Scripts/InstantTracking/InstantTrackingController.cs:130)

 B) Changed License Key with the SDK_TRIAL one and no error in Unity Editor. But the iOS build crash on start in XCode (attached screen)



Hi Alexandru,

 

please not consider previous post.

We forgot add Wikitude.Framework sdk as embedded binary in XCode.

We confirm your Unity example project working.

Just one more something strange: ios device shows "License Missing" watermark instead "Trial" one when we place SDK_TRIAL license to Wikitude Camera in Unity.

We had SDK_DEMO license but was expired while you resolved the issue.

 

Could you renew that license for a little period (just 10 days I mean) in order to test our project?

 

Thanks in advance

Regards

Camillo

This issue has slowed our work and the Demo license is going to expire in one day!!! 

Could you resolve it soon?


Hi, 


Can you please try the same steps as above, but without setting the trial license, and leaving it as it was already set in the project?


Thank you,

Alexandru

I did it. Same problem.

Attached screenshot.


How can I send you the  Unity project and BUILD for iOS?

Image-1.jpg
(603 KB)

Just to pop in and say that we're having the same issue in the topic I started here: https://support.wikitude.com/support/discussions/topics/5000090691


Fundementally its smart tracking turned on, tracking works fine, camera feed does not.

Any updates on this? Been two months since the first report of the issue and two weeks since I established that its an issue in your native libaries.


I would of thought that this is quite serious, any iOS build in any of your native library using solutions may not be able to use SMART Tracking as it'll visually be unusable on the newer iPad we encountered this on (iPad 9.7-inch / 12.1.1).


This issue is solely preventing us buying licences, made equally frustrating by the fact that the ARKit integration is working fine for tracking, just not visually.

Hi, 


Can you please also set the Bundle Identifier to "com.wikitude.unityexample", so that the watermark ("App ID Mismatch") is gone? If that didn't work, can you please check the other samples, for example the "Plane Detection" sample, and see if that displays correctly?


Thank you?

Really? 

I already demonstrated the license is not the problem (screenshots in posts above), if not other devices should show the same issue but they dont.


However please find in attachment screenshots with com.wikitude.unityexample id for scenes:

1) "Instant Tracking - Plane Detection" (SMART disabled/Plane detection enabled) --> No issue!

2) "Instant Tracking - Simple" (SMART enabled/Plane detection disabled,  configuration I need!) --> Same Issue!


May you try for double checking? 

I can even send you the project

Hi, 


First of all, these are the first screenshots that were posted without a watermark. The initial screenshots had the Trial watermark, and the last ones had the App ID Mismatch watermark on them. I knew it wasn't a trial issue, but I wanted to verify that watermark rendering wasn't interfering with the camera rendering.

Secondly, I did try it on multiple devices and iOS versions, but, as you also reported, this only happens on this specific device, which we don't currently have in the office. So the only I can debug the issue is to kindly ask you to try various things.


The only thing left to try is to disable Metal rendering by disabling the "Auto Graphics API" checkbox and removing Metal from the list.


Best regards,

Alexandru

I Apologize for misunderstanding, screenshots above don't contains demo license but I wrote about that test in first post.

 

I attached the screenshots for No Metal test as you suggested with no luck.



NoMetal.JPG
(21.2 KB)
Login or Signup to post a comment