Start a new topic

Camera rendering flickering on iPad iOS 12

Unity Version: 2018.2.17f1

Wikitude vers: 8.2.0 (Trial or Demo license)

Device: iPad 6° gen (3 devices)

BUILD O.S.: iOS 12.0.1, iOS 12.1, iOS 12.1.1

Issue: Camera rendering is flickering in "Instant Tracking - Simple" example scene as attachments


(877 KB)
(818 KB)

3 people have this problem


I'm sorry OpenGL is also not working for you. I also tried again various configurations and all the devices we have, but I still couldn't reproduce the issue.

Please send us a project that reproduces the issue, just to make sure there isn't a configuration difference between what we're testing. Also, please send us the full console log from both the Metal and non-Metal runs.

Thank you,


News about this issue? 

Just to pop in and say that we're having the same issue in the topic I started here:

Fundementally its smart tracking turned on, tracking works fine, camera feed does not.


We're still working on fixing this and we will most likely create a debug build in order to collect additional information. We'll make that available soon.

In the meantime, is it possible for you to test the Wikitude Native SDK, to check if the problem comes from the Unity Plugin, or if it's a general SDK issue?

Thank you,


Thanks for the update. Best we keep this issue in this topic since it appears to be the same and Camillo had it first!

I'll run a build of the Wikitude Native SDK through it this morning and get back to you!

Just some other notes that might help, I tried all major Unity versions (latest / LTS / 2018.2) with the latest sample (8.2), including the 5.6 with the same result.

 Okay, sorry for the delay.

Built from the native samples, no tampering at all we sadly still have the same issue as shown below.

Just the same as Unity, Smart Tracking seems to be the issue. With the plane detection sample (which presumably doesn't use Smart Tracking) working fine.

Let me know if I can be of any more help!

1 person likes this


Thank you very much for testing, both the native samples and various Unity versions.

We will let you know as soon as we have any updates.

Best regards,


Any updates on this? Been two months since the first report of the issue and two weeks since I established that its an issue in your native libaries.

I would of thought that this is quite serious, any iOS build in any of your native library using solutions may not be able to use SMART Tracking as it'll visually be unusable on the newer iPad we encountered this on (iPad 9.7-inch / 12.1.1).

This issue is solely preventing us buying licences, made equally frustrating by the fact that the ARKit integration is working fine for tracking, just not visually.


I apologize that there were no updates on this for a while. The issue is indeed very serious and we should have a fix for this next week. I'll let you know as soon as it's ready.

Thank you for your patience.

Best regards,



Here is a pre-release package that should fix the rendering issue on the new iPads. Please let us know if this fixes the problem for you.

Best regards,


Hello Alexandru, that release worked perfectly thanks very much. Can confirm it works on newer iPads.

One last question then!

We'll be looking to do licencing soon so will this fix be moving to a public release or should we be using the link you've sent? Keep in mind we'll be wanting to do this next week so whatever is fastest for us is ideal.


The fix will be included in the next public release as well, but I don't have a release date for that at the moment.

Please reach out to our sales department for any further licensing questions.

Thank you,


Hi Alexandru,

No luck, but different behaviours.

I tested Unity project inside the folder "\Examples\WikitudeUnityExample".

- Scene: Instant Tracking - Simple.unity

- Unity version: 2018.3.0f2

- Platform iOS


A) In Unity Editor running the scene get the following errors in the Console:


1) first error

Error initializing tracker!
        Error Code: 1004
        Error Domain: comm.wikitude.tracker_manager
        Error Message: Unable to create InstantTracker
    Underlying Error: 
        Error Code: 2001
        Error Domain: com.wikitude.license
        Error Message: The feature usage 'tracking_3d' is not granted with the given license key
    Underlying Error: 
        Error Code: 1010
        Error Domain: com.wikitude.licensing
        Error Message: Platform ["ios","android","uwp"] is not licensed.

  2) no ending error

Could not check if tracking can be started because the InstantTracker doesn't exist!
InstantTrackingController:Update() (at Assets/Wikitude/Samples/Scripts/InstantTracking/InstantTrackingController.cs:130)

 B) Changed License Key with the SDK_TRIAL one and no error in Unity Editor. But the iOS build crash on start in XCode (attached screen)

Hi Alexandru,


please not consider previous post.

We forgot add Wikitude.Framework sdk as embedded binary in XCode.

We confirm your Unity example project working.

Just one more something strange: ios device shows "License Missing" watermark instead "Trial" one when we place SDK_TRIAL license to Wikitude Camera in Unity.

We had SDK_DEMO license but was expired while you resolved the issue.


Could you renew that license for a little period (just 10 days I mean) in order to test our project?


Thanks in advance




I'm glad to hear that the fix is working for you as well.

I'm unable to generate a new license key for you, but please write to our sales team, explaining that an SDK issue prevented you from using your license before it expired.

Thank you,


Login or Signup to post a comment