Start a new topic

Undefined symbols for architecture arm64 error

I'm trying to build my app using xcode 9.4.1 and am getting the following error when building:


Undefined symbols for architecture arm64:

  "_OBJC_CLASS_$_WTArchitectStartupConfiguration", referenced from:

      objc-class-ref in WTWikitudePlugin.o

      objc-class-ref in WTARViewController.o

  "_OBJC_CLASS_$_WTArchitectView", referenced from:

      objc-class-ref in WTWikitudePlugin.o

      objc-class-ref in WTARViewController.o

     (maybe you meant: _OBJC_CLASS_$_WTArchitectViewController)

  "_OBJC_CLASS_$_WTAuthorizationRequestManager", referenced from:

      objc-class-ref in WTWikitudePlugin.o

  "_kWTScreenshotSaveModeKey", referenced from:

      -[WTWikitudePlugin didReceiveDidCapturedScreenNotification:] in WTWikitudePlugin.o

  "_kWTScreenshotBundleDirectoryKey", referenced from:

      -[WTWikitudePlugin captureScreen:] in WTWikitudePlugin.o

      -[WTWikitudePlugin didReceiveDidCapturedScreenNotification:] in WTWikitudePlugin.o

  "_kWTUnauthorizedAppleiOSSDKAPIsKey", referenced from:

      +[WTWikitudePlugin composeFailingAPIAuthorizationMessageFromError:] in WTWikitudePlugin.o

      ___34-[WTWikitudePlugin requestAccess:]_block_invoke in WTWikitudePlugin.o

ld: symbol(s) not found for architecture arm64

clang: error: linker command failed with exit code 1 (use -v to see invocation)


1 person has this problem

+1 also seeing this, same xcode version.


1 person likes this

Hi, 

Can you share some more details about the project settings that you changed in order to include the Wikitude SDK to your project?! Without any additional information it's hard to judge what's wrong.


Best regards,
Andreas Schacherbauer

Login or Signup to post a comment