Start a new topic

Videos not playing ( but one does)?

I am working with Wikitude Studio, using external mp4s in a fun Twelve Days of Christmas project. It's not finished yet (work in progress). The project url is 5bed77930d87af0d77e1ee2d 

The trigger images are here: 

The videos are here in this format: - change the number down to

Most of the images trigger fine, and show the video box, but only the first video actually plays (which may be internal, I can't remember).

Note: It would be useful to be able to see the URL of a video (and if it was internal or external) 

I added number 9 (ladies dancing) as internal and the animation triggers, and shows but doesn't actually play.

Additional question: When using Wikitude on a device, I DO have to leave the project then re-enter it every time I make a change to project in wikitude Studio right?

Can you figure out why my videos aren't playing (but the first one is)?  They all play fine in VLC/Quicktime player...And are H.264 1000x750 and quite small, most under 10MB.

Thanks for your help...


p.s could you cc in me on  if possible.

1 Comment

Hi Tom,

We just tried to replicate your issue by uploading your videos to a new project. We tried hosting the videos via an external URL and an internal URL. In both cases, the video was displayed and started playing.

The larger video needed quite some time to load, though.

Regarding your issue:

When the "Play immediately" option was checked, the video only played on first recognition, not on consecutive recognition. As a workaround, you could use the "Resume on recognition" option. That way the video will be resumed where it stopped when recognized again.

We'll put the reported bug in our issue tracker. Please keep looking for updates in the Wikitude Studio release notes. If you have any further questions, please don't hesitate to contact us again.

Login or Signup to post a comment