Start a new topic

Wikitude Crashed on IOS Error: VertexFunction must not be nil

Hello, 


as the title mentioned, for our Stand Up AR application, our team tested Wikitude SDK8.0 and 8.1. Both crashed on iOS when Wikitude camera was loading. Testing environment:


Unity 2018.2.7f1

Unity 2018.2.10f1

Wikitude SDK 8.0 

Wikitude SDK 8.1

Xcode 10 release

iOS 12

iOS 12.1


Unfortunately, none of the above combinations works. We need an urgent support on this project. Thanks!


image



Please note that we were able to successfully build to Android on the same laptop using the same Unity project.  It is only the iOS build that fails. 

Please note that we were able to successfully build to Android on the same laptop using the same Unity project.  It is only the iOS build that fails. 

Hi,


Are there any errors printed to the console before the freeze happens? If, in Xcode, you pause the execution of the app while it is frozen, can you see in which part of the code it is stuck? Is it possible for you to test on a different, possible not iOS 12 device, and see if the problem still occurs there?


Thx and greetings

Nicola

Hi Nicola,


iOS 12 is the only device we have currently. Yes, the error is as the topic suggested:

Error: VertexFunction must not be nil.  

Besides, you may want to contact Paula because she has our whole project zip file. We appreciate your help!


image


Hi Nicola,


as the topic mentioned, 


Error: VertexFunction must not be nil


Unfortunately, we have only an iOS12 device. We didn't pause the execution, probably. It paused automatically because of the above error. We were not able to debug it because it seems from Wikitude Camera. Besides, in your forum, if we search vertex, we may find a few similar open questions.


Ms. Paula Perrichot has our whole project zip file. Would you please get a copy from her for debugging? We appreciate your help very much!



image


Hi, 


I was able to reproduce the issue with the attached project. However, simply updating the project to version 8.1 fixed the issue for me. When updating, please make sure that the contents of the following folders are completely overwritten with the new version:

  • Assets/Plugins/Android
  • Assets/Plugins/iOS
  • Assets/Plugins/WSA
  • Wikitude/Dependencies
  • Wikitude/Editor

Once this is done, you will probably get a compilation error in SceneTrackingController.cs, complaining that "Plane" is now ambiguous. Simply use UnityEngine.Plane instead and the compilation errors should disappear.


This is an iOS 12 specific error, and since Wikitude SDK 8.0 was released before iOS 12, there was no way for us to prevent it, unfortunately.


If you still have issues getting the app to run, please let us know.


Best regards,

Alexandru

Login or Signup to post a comment