Start a new topic

3d encoder crashes/black screen

Trying to convert and FBX file from to a WT3 wikitude file.

First, the screen is all black but I can still click the menu items so i can load a FBX file.

When I do it crashes every time. screenshots included. 

Windows Server 2008. Not sure of OpenGL version.  I have also tried it on 3 other windows machines. Windows 10. All have either crashed at app launch or when loading a FBX file.

Do you just recommend using a MAC? I have even tried spinning up a windows machine on Rackspace... anything to convert a file. please.


we're aware that the 3D encoder does not work on a lot of Windows machines. Unfortunately, we've not yet been able to resolve this issue. I'm afraid the only reliable way to use the encoder is on Mac OS. 

What you should be able to do, though, is use the underlying command line encoder directly rather than relying on the GUI application to do so. This binary is located in <3D_ENCODER_ROOT>/tools/win. Running the following command should yield a model file that can be loaded by the Wikitude SDK.

gameplay-encoder.exe <FBX_INPUT_PATH> <WT3_OUTPUT_PATH>

- Daniel

OK, I found another Windows machine to run it on. I works MUCH better now. I have already done a few conversions. Thank you.

Login or Signup to post a comment