Start a new topic

SDK 8.1 Xamarin PlatformBridge is not defined

I'm using Xamarin to test my application, when I try to debug it the only error I get is:


Uncaught ReferenceError: PlatformBridge is not defined

    at Object.callAsync (architect.js:1)

    at c.init (architect.js:1)

    at c.(anonymous function) [as init] (file:///C:/Simon%20AR%20Project/AR/Wikitude/xampTest/xampTest/xampTest.Android/Assets/js/architect.js:1:4803)

    at new c (architect.js:1)

    at Object.createOverlaysFn [as createOverlays] (ImageRec.js:16)

    at Object.initFn [as init] (ImageRec.js:7)

    at ImageRec.js:71


This is a function called/created in architect.js but it doesn't work somehow. 


Good morning Simon,



would you mind letting me have your `ImageRec.js` file (including resources) so I can try to run it and check what happens with my setup? Based on the error message, I can't tell why this is happening for you.



- Daniel

I think I got it working already. I used the studio to export the file to offline version. Using it this way I can use the code. Btw maybe i just messed up but when I tried to use the html file locally with the code from your example it didn't work. But when I set up a website the html could be reached, and using the exported html from the studio it worked locally too somehow.

I had your example local index.html in the same file as the studio exported index.html

Login or Signup to post a comment