Start a new topic
Solved

Example not fired

Hi, i'm new on Wikitude and i try to use example (the first one).


I have install the sample on my web server by copying all the file et i use my iPhone 6 under ios 11.4.1 but nothing appears. The screen displays only loading ... when i shoot the picture !!!!!


What it wrong ?


Merci pour votre aide.


Hi,


Did you follow the steps of the setup guide exacty as mentioned in the documentation? If not please revisit the guide. Also, did you find any issues in the logouput?


Greetings

Nicola

Hi,


In the sample, the script https://www.wikitude.com/libs/architect.js can't be load and i don't understand why it doesn't exist on server.

What is wrong ?

What can i do ?


Greetings.

Olivier.

Did you check the documentation and the explanation regarding the architect.js file:


http://www.wikitude.com/external/doc/documentation/latest/android/samples.html#including-the-architectjs-library


If not, please have a look at it and if the problem perisist with the sample app, please let us know about the exact issues.


Thx and greetings

Nicola 

Hi,


I experience the same problem on iOS 12.01 and an iPhone X with the Javascript SDK.

First, I opened the project in XCode and ran it on my iPhone. All examples worked the way they should.

Then I copied the "01_ImageTracking_1_ImageOnTarget" files to my server.

Next I replaced the index.html in the example by a new index.html with the following code:


<!DOCTYPE HTML>

<html lang="en-US">

    <head>

        <meta charset="UTF-8">

        <title>Page Redirection</title>

        <script type="text/javascript">

var root = "https://marways.com/wikitude/test1/index.html";

window.location.href = root;

        </script>

    </head>

    <body>

    </body>

</html>


When loading the app and starting the example, the "Loading..." bar appears, but that's it.


When calling the index.html on my desktop browser and clicking the ADE button, all objects seem to be in place. But nothing happens.


What am I missing?

Hah, I solved the problem!

Keep the original index.html as it is except changing the URL to the specific js-file.

It seems that the framework js-files need to be called on the device to set the connection.


Login or Signup to post a comment