Start a new topic

Issue with video augmentation in iOS

I have a single issue with one image and associated augmentation that I can't figure out. It plays as expected on Android but not iOS. The recognition seems to occur but the video doesn't start on iOS but works as expected on Android. Previously used content with similar settings continues to work and does not exhibit the problem. I uploaded the video via the studio editor so nothing to do with it being external content. This one has me a bit stumped.


Hi Logan,


I just tested with with the latest Cordova sample app - I uploaded your complete experience to a server and entered the link to the index.html file to the 'Enter World URL' section and tested with the Samsung S7 and the iPhone 8 and the Herbal-Cartoon video was shown. Can you please recheck on your end and if the problem persist, please try the same approach as I did and let me know the exact steps to reproduce this issue.


Thx and greetings

Nicola

The issue is with Herbal-Cartoon.

Hi,


I quickly check the videos and if it's the video for FeatureFigure_Poster then the reason might be the dimensions of the video. You can find details on video augmentations and the max dimensions here:


https://www.wikitude.com/external/doc/documentation/latest/android/video.html#general-notes-about-videos


If the issue perist or you're referring to another video, please let us know.


Greetings

Nicola

Here is the offline JS version of the project. 

zip

The project is at https://studio.wikitude.com/projects/5afd5650adb1e703e6a9c171 and the content in question is https://studio.wikitude.com/projects/5afd5650adb1e703e6a9c171/studio/5b5b0c2f54b4d93c9742dec1. Let me know if you need me to share it in a different way. The SDK version is com.wikitude.phonegap.WikitudePlugin 7.2.1. It happens on multiple iOS devices and occurs inside my app as well as the Wikitude app.

Hi,


Can you please share your complete Studio Editor project? Please also let us know which SDK version you're testing with? What device this is happening on? If this is happening in the SDK sample app or your own app?


Thx and greetings

Nicola

Login or Signup to post a comment