Start a new topic

Wikitude camera not working with multiple Unity scenes

Hi,


I am creating an application for Android. When I builded a project consisting on few Unity scenes, Wikitude camera stopped working (it's showing white screen). When I'm testing scenes separately, everything is working fine.

 

Can anyone help? :)


Hi, 


This problem should be fixed in the latest version of the SDK (version 8.0.0).

If you cannot update to the new version and still have to use 7.2.0, please make sure that Multithreaded Rendering is disabled in Player Settings -> Other Settings. The scenario you described should work fine, so I suspect there is a difference in how the projects are configured.


If the issue still persists, please send us a project that reproduces it at support@wikitude.com and we will debug the problem further.


Thank you,
Alexandru

Unity version: 2017.3.1f1
Wikitude SDK: I guess this must be 7.2.0
I'm testing on device with Android 6.0.1 MMB29M

In one scene I'm detecting the ground, in another one - the image. In separate scenes everything works. The issue occurs when I have a project with multiple scenes and I'm switching from one scene to the scene in which I'm using Wikitude. Other elements on the scene are working but here's no view from the camera, just white background.

Hi, 


Can you please provide some additional information?


Which version of Unity and the Wikitude SDK are you using?

On what devices are you testing?

What kind of tracking are you using when the issue occurs? Does the equivalent sample work fine in the example project?


Thank you,

Alexandru

Login or Signup to post a comment