Start a new topic

Object Recognition not working (SDK 8 + Unity)

Hi everybody,

hopefully I'm in the right section...

I have a little problem to get the object recognition running and it would be great if anyone could help me out with it.

I have followed the instructions for unity: and also the tutorial on youtube:

Sadly I couldn't get anything to work as expected.

I'm not quite sure if there is a problem with the wto file or a general one.

Currently I'm using SDK Version 8, so I had to upload 30 images to the targets manager and got a wto file which I have placed into unity as in the tutorial. My WikitudeCamera Object is also set and there is the licence key inserted. Also I have created a small cube which should be shown after the recognition. If I try to run the application on my phone there comes a message with trial all over the screen and then everything is freezing. If I run it on my desktop I see the webcam video but nothing happens if the object comes in view...

I have also tried to change the wto file in the sample with mine, but that doesn't change anything.

Would be very cool if someone has a idea what I could try next, or maybe what I have not done right...

Thanks a lot!

1 person has this problem

The sample app runs without a hitch on Xiaomi Redmi 5 Plus with API level 25... So maybe the issue is in graphics API? Tho, glasses have  OpenGL ES >3.0 as well as Xiaomi phone.. But slightly lower API level.


Regarding the focus issue, the device can only render the augmentations at a fixed focus distance, so when the target doesn't match this distance, you can either focus on the target, or the augmentation, but not on both at the same time.

The screenshots seem to look fine. The device stretches the rendered image to cover both eyes, so if you stretch the screenshots to double their original width, they don't appear distorted anymore. Does it look different when looking through the glasses?

Unfortunately, we don't have a calibration file for the bt-350.

Best regards,



Does this info help:

Please also make sure that you use the latest beta available and to follow the instructions from the documentation that is included the Unity Beta SDK download package.

If the problem persists, please provide further details (Platform, error log,...).

Thx and greetings


Hi Nicola,

thank you for the fast respond.

I'm quite sure, that I use the latest version and followed the instructions.

Unfortunately the info didn't helped me, I forgot to say, that I'm trying to develop an Android App. My development host is a Win 10 machine.

There seems nothing to be wrong with the build itself, because I do not get any errors. But after the app started on my Android device the first image that the camera gets stays there. Screen is never updating and it seems that the app crashes.

I'm not quite sure where I should get an error log from. I found nothing helpful on my device. In the class path are only some files from unity Analytics and my wikitude wto file.

Thanks for you help and best regards,



Can you please provide further details on the following:

Unity Version

Android Device

Android OS

Are other samples working as expected? Can you try e.g. with an Image Recognition sample.




Do you have any other device that you can test on? Since we didn't get any similar reports and we couldn't reproduce your issue ourselves, we'd like to know if this problem is only happening in the P8 Lite.

If that still doesn't work, could you please send us the logs from the device when the issue is occurring? 

Thank you,


Here we go...

Unity Version: 2018.1.6f1 Personal (64bit)

Android Device: Huawei P8 lite (Buildmodel ALE-L21)

Android OS: 6.0 - API Level 23

I tried to run the Image Marker - Simple. It's running perfectly on desktop but on my phone I got the same "error" / behaviour as before. After loading the camera view, the app freeze with the first image.

I have the following build options:


And these are my player settings, or let's say the important part of it.


Do you have any ideas? Thanks again!

Pardon me, I haven't noticed that Epson Moverio SDK has already provided 3d object tracking. The sample project for Epson Moverio works, though in 3d mode rendered 3d objects are seem to be squeezed along Y-axis.

Maybe I haven't callibrated a cam carefully enough, maybe issue is in interpupillary distance or something, but in 3d mode objects are highly indistinct, hurt my eyes

Good day!

I have a similar issue - can't get the object recognition to work on android devices. Video input from camera doesn't show up on the display. I can see only black screen with wikitude watermark and "trial trial trial" on the background instead.

I followed this video tutorial too:

Wikitude unity plugin version 8.0

Unity 2018.2.0f2 personal

Android device 1 - Philips V387, API version 19, OpenGLES 2 (blank black screen)

Android device 2 - Epson Moverio bt-300, API version 22,   OpenGLES 3.1 (black screen with "trial-trial" overlay, nothing happens)

Though the app works in unity editor and even tracks the object.
Please, help!

Thank you in advance

Hello, Alexandru,

I've switched to unity 2018.1.9f1 but got the same result, unfortunately. What else can it be?

Here are my player settings:



Do you have any other device you can try on? We weren't able to reproduce your issue here.

Thank you,


Hi Alexandru,

thank you for your reply. Sadly I do not have any other device to try on. But because I'm running out of time to finish it, I have choosen another solution. (Using a simple image marker instead)

I guess you can close this, thank you for your help!


Can you please try the project provided in the download package, without any modifications with Unity 2018.1? Hopefully that will tell us if the issue is with the project setup or with the device.

If it still doesn't work, can you please post the console log from the app when the SDK is starting up?

Does the issue happen with image or instant tracking as well, or only with object tracking?

Thank you,


Hi, Alexandru,

Unity warns that the project, namely wikitude example, was saved with another version of unity and gives no other option than re-import assets on startup. So when I do that Unity opens up an empty scene. The project tree is default: main camera, light.
So it seems like unity modifies it somehow anyway...

Login or Signup to post a comment