Start a new topic

Getting Build Error: A library uses the same package as this project: com.wikitude.unity

Hello dear community, 

I am trying to build the sample scenes provided in the SDK for Android but I am getting the error as listed above:

A library uses the same package as this project: com.wikitude.unity

Of course my package name is not the same. The Unity version is 2018.1.0b11.

Can  somebody help me out here please?

Best regards

I had the same problem, but I was able to fix it by changing the 'Build System' type. i tried the new version you provided, it fixed my problems. 



1. Object rotation is not currently implemented in the sample, so unfortunately there is no code for that at the moment. Dragging and scaling are controlled through the MoveController and ScalingController scripts, so you can have a look at those and extended them to also support rotation.

2. IL2CPP is a Unity technology that converts C# code to C++. This can help with performance, and is required on some platforms, for example iOS or 64 bit Android. It does require Android NDK. If this is an issue for you, you can switch back to the Mono scripting backend. You can read more about IL2CPP here.

3. The ground plane is controlled through the _gridRenderer variable in the InstantTrackingController. To disable it, simply run _gridRenderer.enabled = false when you want it to disappear. The InstantTrackingController, as well as all the other scripts in the project, are provided as an example only, so feel free to modify or replace them entirely to fit your project.

Best regards,


It works!  The beta Unity 8.0 builds to the android phone successfully.  It is slightly different than the android studio version, but still functions in the same way.  However, I have three questions...

1.  How can I implement object rotation? (the Adroid Studio version lets the user roate the clock, couch, etc...with your fingers.  The Unity build does not and I did not find a script for rotation control.  Any suggestions or code for that??

3.  How can I implement the ground plane registering such as in the android studio build?  The unity build just scans for a gound plane and leaves the grid permanently.  I like the android studio versions ability to register the ground plane with the green play button, and then the grid is not visible.

2.  I had to download Android NDK to build the app because backend scripting set to "IL2CPP" in player settings of wikitudes sample projects.  What is the purpose of this?

Thank you for the help.  We are purchasing a license soon and are excited to start development.

I just fixed it myself. The project that you provided has Android API 16 set. This doesn't work with wikitude appearantly. It needs to be set to API level 19 at least. Maybe you update that in the sample projects and your docs :-).


Hello Alexandru, whenever I try to build the instant-Tracker sample scene in the sample folder from the sample project of the beta, the app crashes on startup on my android device. Can you help  me out here?


Please try the new 8.0.0 version that you can find on our downloads page under the Beta tab. It should provide better support for newer Unity versions.

In regards to the Instant Tracking sample, the one from Unity contains roughly the same functionality as the Interactivity sample from the Javascript Android SDK samples.

Best regards,


Also..I am given the option to select 'interactivity' after selecting 'instant tracking' in the Android SDK build of wikitude examples.  However, when exported from Unity the app never gives that option after selecting 'instant tracking'.  Could their be something wrong between selecting 'interactivity' and which type of interactivity??

Thanks.  I tried changing Build System from 'Gradle' to 'internal' and the app will finish building in both Unity 2017 and 2018.  However, the app never finishes opening on the phone.  It just crashes and says 'restart app'.  Any ideas?

phone - samsung galaxy s7

version - 7

Unity - 2017.3 and 2018

I had the same problem but solved it by changing the 'Build System' type. Change the 'Build Settings->Android->Build System from 'Gradle' to 'internal'. Hope it helps.

I successfully built and ran the unmodified sample instant tracking application using Unity 2017.3. ( It failed to build in 2018.1) With my own company and product name in player settings for android. However, the application only shows a white screen with ground finder grid and never activates the camera or model furniture. Its a samsung galaxy s7 with android version 7.


Are you building the apk directly in Unity, or are you exporting the project first and then building it?

Does this happen with our unmodified sample project as well, or only when importing the package in a new project?

Thank you,


Same issue.  Any luck?

Also Unity 2017.3.1p1 (64-bit)

I have also experienced the same behaviour running Unity 2017.4.1f1 and the latest Wikitude.

Best regards


Does this also happen with stable releases of Unity (2017.3 for example)?

Thank you, 


Login or Signup to post a comment