Start a new topic

Version Conflict on iOS

I'm using the cordova plugin and I receive the following message when initially when launching wikitude.


Version Conflict

The used wikitude sdk is not supported.


The message doesn't appear again once I dismiss the window and go back into the wikitude view. 


Android is just fine.


Anyone experience this before? 


Hi,

we solved the problem by manually triggering the camera permission prompt before entering the AR View, because it seems the the Wikitude Cordova plugin triggers the permission after initializing the AR view on iOS causing that error message the first time the AR View is accessed on the App.

Hi,


Which SDK version are you working with? Are you working with the JS SDK? Is this happening with the unchanged SDK sample app? If so, please put your Studio experience on a server and share the url to the .html file so we can test.


Thx and greetings

Nicola

Hello,

we are experiencing the same issue with iOS on the first attempt to launch the AR view, with contents created with Wikitude Studio. 

Is there any solution to this problem?

Discussion has been moved to a private channel

I did not see this in earlier versions of my app. Should I rollback to a previous version of the plugin or is it something you introduced studio side that is now causing the problem. 

Hi Logan,


We are aware of this issue and unfortunately we do not have a fix right now. The problem is the permissions regarding the interaction between Studio and the SDK app. Could you please try and load your studio url with our sample app and see if you are getting any issues there?


If not then I would suggest that you follow within your app the exact same steps that we define in the sample app.


Thanks

Eva

Just want to clarify with regards to the studio. I used the cloud studio to create the package but I'm just using it locally in my project. I receive the permissions prompt when I initially launch the AR view but then the error message presents itself. The issue seems to go away following this initial launch and permissions request and I go back inside the AR view. I don't have this issue on Android. 

Hi Logan,


Did you make sure that all the needed permissions are set before you start the AR view? It might be that when the Studio url is called and the permissions are not set before that the SDK version number is not set and sent. 


I assume the sample app is working for you if you load the Studio project url (url.wikitude.com...). 


Eva

I use the cloud studio.

Hi Logan,


Are you working with Studio?


Eva

Login or Signup to post a comment