Start a new topic

Unable to load Target collection resources

Hello Alex,

I am trying to load .wtc file in a cordova android based project. In the project i am loading a set of target as follows.:

this.targetCollectionResource = new AR.TargetCollectionResource("assets/", {

   onLoaded: function () {

    World.resourcesLoaded = true;


   onError: function(errorMessage) {

       console.log(" Error loading the target collection ");



I have tried all permutations but "assets/" does not get loaded at all and the "onError" function keeps getting called with no meaningful error message. 

NOTE: The assets are all in the right folder locations and are not corrupted

I have attached an alert message when the above code is executed and my folder structure.

Could you let me know what might be problem???

Also could you suggest a way to debug the code? As this piece of code does not appear in Chrome Remote debugger. It is very tough to make judgments.



1 Comment


As the ticket has the status solved, I'm assuming you solved the issue on your end. If not, please change the status back to 'unsolved'. In regards to your issue: does this issue also occur when you test with the Wikitude Cordova Extension sample app? If not, please have a close look at the structure and code of the sample app togehter with the documentation.

Thx and greetings


Login or Signup to post a comment