Start a new topic

Titanium + iOS device + POI drawable image is not displaying

 Hello Wiki tude Team,

I am using Titanium app and trying to load POI item on iOS device and my problem is that the POI draw-able image is not displaying my sample code is like that


World.markerDrawable_idle = new AR.ImageResource("assets/marker_idle.png", {
            onLoaded : function(width, height) {
                alert('Resource loaded!');
            },
            onError : function(e) {
                alert('An error occurred loading the resource!'+JSON.stringify(e));
            }
        });

OR

World.markerDrawable_idle = new AR.ImageResource("assets/marker_idle.png");


 In marker.js file


this.markerDrawable_idle = new AR.ImageDrawable(World.markerDrawable_idle, 2.5, {
        zOrder: 0,
        opacity: 1.0,
    });

    this.titleLabel = new AR.Label(poiData.title.trunc(10), 1, {
        zOrder: 1,
        translate: {
            y: 0.55
        },
        style: {
            textColor: '#FFFFFF',
            fontStyle: AR.CONST.FONT_STYLE.BOLD
        }
    });

    this.descriptionLabel = new AR.Label(poiData.description.trunc(15), 0.8, {
        zOrder: 1,
        translate: {
            y: -0.55
        },
        style: {
            textColor: '#FFFFFF'
        }
    });

    // Changed:
    this.markerObject = new AR.GeoObject(markerLocation, {
        drawables: {
            cam: [this.markerDrawable_idle, this.titleLabel, this.descriptionLabel]
        }
    });


Eventhough All assets images are present in assets folder with same name but I only seeing the labels on Geo POI items but World.markerDrawable_idle is not displaying.


I am using latest ade.js file and 7.2.1 wikitude module and Titanium  6.2.2.GA sdk.


Can any one help me..


Hi,


Did you try with our sample exactly as we provide it, to see if you can load the image there?


Thanks

Eva

 I have debug more and found that in onError method It is through  attached error. 

Hi,


Can you please send your complete AR experience (.html, .css, .js files, assets, target images) so we can test internally?


Thanks

Eva

Hello again,


Could you please download the package from our official Download page here and test again?


Thanks

Eva

Please find the attached wikitude folder and I am using


geo_index.html


multiple_geo_pois.js

marker.js

myjsonData.js etc files for generating POI.

zip
(266 KB)

I am already using the latest Wikitude SDK 7.2.1 from your official site.

https://www.wikitude.com/download/

For Titanium and running on iOS device.

Hello WikiTude Support Team,

Hope you are doing well. And thanks for your quick response.

I have created one Titanium sample ios project in which I am trying to integrate  POI with Label feature. And that project contains all latest configurations

i.e Titanium SDK 7.0.2 , Wikitude SDK 7.2.1 from your official site (https://www.wikitude.com/download/ ).

I have used the same code/folder that is mentioned in wikitude titanium samples for achieving POI with Label and here is the link I am following


https://github.com/Wikitude/wikitude-titanium/blob/master/WikitudeTitaniumSample/Resources/iphone/08_PointOfInterest_2_PoiWithLabel/index.html

But when I am running the project on my iOS device it is only showing Title and Description Labels to me it is not displaying the drawable-image to me.


So can you please find the attached project and resolve my problem asap as we need to deliver GEO AR feature to our client in very tight lime lines.

Project Running Configurations :

1 Put the package name in tiapp.xml file with in id tag and that file is located at Wikitude_Geo_AR/tiapp.xml.
2 Put the Wikitude Token key  in index.js file  and that index.js file is located at Wikitude_Geo_AR/app/controllers/index.js

Project Google Drive Link To Downloadhttps://drive.google.com/open?id=1mp4KDFn1AMqqFkzafK-ZmcMjj_DyZs9s


I think Sample Project expected behavior will be like attached image in wikitude docs.


Waiting your feedback.

Good morning,



my apologies for the delayed response. Is this issue still current?


Based on your description and the error log you posted I suspect the marker_idle.png file may simply not be bundled into the final application. Did you set up your project in a way such that it should be included?


You can generate an IPA file and check the content thereof to find out whether my suspicion is correct or not.



- Daniel

Small follow up question:


Does this happen on Android as well?

Login or Signup to post a comment