Start a new topic

Breaking Changes to your Manager API

Hi there, I have several functions on our website that rely on the Target/CreateTargets endpoint of your Manager API.  I am not sure what you guys updated yesterday but it seems that the endpoint is no longer returning information about the target that was created in the session.  Luckily I have logs from before you guys made the change:

{ status: 'COMPLETED',
   { userId: '58a7486a8e601c9c388d6922',
     targets: [ [Object] ],
     tcId: '58ab55fc59c5f6ab3807e0e9' },
  payload: [ { input: [Object], target: [Object] } ],
 ***^^^^**** Right here the "target" object is no longer included in the return values!!
  estimatedStart: 1519687936506,
  estimatedEnd: 1519687941506,
  estimatedLatency: 5000,
  generationId: 'ryLZKGMuM',
  created: 1519687934506 }

In addition to this, the endpoint also used to return an error object in the first position of the payload array when there was an error adding the image to the Target Manager such as transparencies, etc.

If you have made changes to this interface, could you please describe to me how we are supposed to now get the new target information star rating and/or any errors from this endpoint.

Please check again, this issue was resolved already yesterday.

We checked many times and again have just tried now - just a moment ago. Whatever the issue is, it is surely not resolved. Please have another close look at the clear information that we have provided.

It is important to note that this is a mission critical system for us, so we can not afford to let entire days pass with not more than a "try again" response from you.

Thank you for your due consideration with this.

Hi there,

I have just checked again as of the time posting this message and there are still no target objects nor any error objects being returned from the endpoint.  I am using the North American server if that helps.  

Hi there,

We checked again when this response was posted as well as at the time of writing this reply.  There is still no target or error information being returned.  We are using the North American server if that helps!

We really appreciate any help we can get asap as this is majorly affecting our clients!!!

Thank you!

Please check again, this issue was resolved this morning on the  the North American servers.

Login or Signup to post a comment