Start a new topic

Sample SLAM scenes not working Unity / Android

Downloaded SDK 7.2.0.  Using Unity 2017.3.0f3.  Created new unity project.  Imported Wikitude package.  Pasted trial license into WikitudeCamera prefab. Built sample scenes to Samsung Galaxy S6.  Go to Instant Tracking sample.  

Sample scene loads up - with height slider and ground grid.  When I hit initialize nothing happens.  Looking into the code, it appears it's supposed to change the state to "tracking" and turn on some buttons of objects to be placed in AR.  It does get to the OnClick button event, but the state change doesn't seem to happen. 

Also tried Scene Picker -> I hit "Start Tracking" and it changes to "Switching state..." but stays like that forever.

These samples aren't working out of the box for me, and I haven't the foggiest idea why.  Please help.


Can you please also try the example project provided in the download package as well? I tested that with the same Unity version and phone and it worked ok for me.

If it still doesn't work, can you please post here any errors that you get from the Android console?

Thank you,


That's exactly what I did.  I built the sample project and tested the 2 instant tracking scenes.  Neither one would go into "tracking" state when the button was pushed. ("Initialize" on the Instant Tracking scene, and "Start Tracking" on the Scene Picker scene).  

It's also not working on iOS.  One thing to note is that the overlay states "Unlicensed Feature Used" as opposed to Trial.  

No errors in console for either Android or iOS.  The problem is that the state isn't changing to "tracking".  

For more information, all of the image tracking scenes work fine.  They also have the "TRIAL" overlay.  My only issue is with instant tracking. <- showing instant tracking and/or scene picker not working

I've tried building the example project with wikitude sdk 7.1 and it worked - issue seems to be 7.2 specific.


Thank you for bringing this problem to our attention. There currently is an issue with old trial licenses in the latest version of the SDK. We'll release an update that fixes it soon.

Until then, you can either try to generate a new license key by creating a new developer account, or use the trial license and bundle ID from the example project provided.

Thank you,


Login or Signup to post a comment