Start a new topic
Solved

Problem running sample scenes

I'm running Unity 2017.3 0b6.  NDK 13.b.  Android SDK 26.  


I built the app from Unity and ran it on a Samsung s8.  The main menu is showing up OK.  When I click on an example, I get a garbled result.  I'm able to hit back to the menu.  In Logcat, I see the following: 

01-08 12:35:08.064 15916-15945/? E/Unity: AndroidJavaException: java.lang.NoSuchFieldError: no "Ljava/lang/Object;" field "ctx" in class "Lcom/wikitude/unity/WikitudeActivity;" or its superclasses
                                          java.lang.NoSuchFieldError: no "Ljava/lang/Object;" field "ctx" in class "Lcom/wikitude/unity/WikitudeActivity;" or its superclasses
                                              at com.unity3d.player.UnityPlayer.nativeRender(Native Method)
                                              at com.unity3d.player.UnityPlayer.c(Unknown Source)
                                              at com.unity3d.player.UnityPlayer$c$1.handleMessage(Unknown Source)
                                              at android.os.Handler.dispatchMessage(Handler.java:98)
                                              at android.os.Looper.loop(Looper.java:154)
                                              at com.unity3d.player.UnityPlayer$c.run(Unknown Source)
                                            at UnityEngine.AndroidJNISafe.CheckException () [0x00000] in <filename unknown>:0 
                                            at UnityEngine.AndroidJNISafe.GetStaticFieldID (IntPtr clazz, System.String name, System.String sig) [0x00000] in <filename unknown>:0 
                                            at UnityEngine._AndroidJNIHelper.GetFieldID (IntPtr jclass, System.String fieldName, System.String signature, Boolean isStatic) [0x00000] in <filename unknown>:0 
                                            at



The latest release works. Thanks!



Hi,


We just released version 7.2.0 of our SDK, which includes support for ARKit and ARCore, as well as some fixes for Android. Can you please check if this version works for you?


Thank you,

Alexandru

Just tried it with 2017.3.0F3 on a Pixel 2, but unfortunately got the same result.

Also, if you are using IL2CPP, can you also try with Mono to see if that makes a difference?


Best regards,

Alexandru

Hi, 


I apologize for the late reply. I tested with 2017.3.0f3 on a Samsung S8 and it seemed to work fine for me. Can you please try with a non-beta version of Unity?


Thank you, 

Alexandru

It happens with the sample project.

Hi, 


Does this happen when using the example project provided in the package, or when integrating the Wikitude plugin in your own project?


Best regards,

Alexandru

Disabling multithreaded rendering in Player Settings > Other settings fixed the garbled image issue.  Now screen for examples shows a clear header, but is still unresponsive.  The error in the log still shows up both when clicking on a sample, but clicking back.

Login or Signup to post a comment