Start a new topic

Setting up a proper project

 We are trying since days to get a simple Wikitude sample working but with no success so far. 

We like to develop a Cordova smartphone app without using Xcode or Android Studio.

What we have in use is the PhoneGap Desktop App and as well the Cordova CLI.
It seems there are many different ways to create a project which is where the first problem starts. 
Creating a Wikitude project with the Desktop App and creating a project according your documentation with Cordova CLI already creates different files and folders (just looking at the config.xml or the folder structure). So not sure, which variation is the correct one.

In the documentation the correct folder structure is described but for example in your Target Image sample not even a "www" folder exists.

Creating a Wikitude project with PhoneGap Desktop sets up the red T-shirt project. This works fine and we are able to scan the T-shirt and seeing the eyes blinking. 
But wondering why there is no "src" folder with the WikitudePlugin.js available in the project as in every other project were we have to enter our license key? The folder structure is also very confusing because there are at least four www folders...

Therefore we downloaded the whole Wikitude sample package from Github entered our license key and tried the Image Target sample which ended with an error. Daniel Guttenberg confirmed on GitHub the sample package is not up-to-date, so we downloaded the samples directly from (Cordova). 

Still the big question is how exactly set up a project properly and where to place the code for example for an Image Target App.
Trying out the "Using the Wikitude Plugin to create your own augmented reality experience" seems to have again another approach to setup the project and include the needed code.

Some help to setup a Cordova project correctly with the correct folder structure and the correct config.xml would be very helpful. We faced some problems when we tried to build our project ( because some entries in the config.xml were not valid...

Thanks a lot and regards...

Login or Signup to post a comment