Start a new topic

Wikitude NativeAndroidSDK unable to run the examples

I'm new to this SDK. When I tried to run the AndroidNativeSDK examples, I ran into errors shown in the following inserted pics.

Hope someone can help me out! 

Thank you very much!



(3.36 KB)
(7.15 KB)

Plus:There are several errors similar to the first one I inserted.

Hello Yuhao li,

Our new SDK 7 requires iOS 9 or later since the Wikitude Native SDK is configured as a dynamic framework to support ObjC and Swift.



But what I download is SDK for Native Android. I don't think there is anything about iOS. 

Hello Yuhao,

That was my fault. Which version of the Android Studio are you using?



I have the same problem with Yuhao, when I try to run 7.1.0 example. 

But wikitude5.0.0 example is work on my computer.

 And I use the android studio 2.3.3. The version of NDK is 14. 

Is there anyone can help me solve the problem ?

Thanks very much!


so far we only had people report this issue with NDK 16. We will take a look into this issue.

If you do not require the Plugin samples to work you could just remove the dependency to the plugins module in the build.gradle of the app module and try it again. 

If you want to try the plugins sample you could also try to remove the x86 configuration, since it seems to be only an issue of this architecture.

Best Regards,


Thanks for your solution.

Remove the dependency to the plugins module in the bulid.gandle of the app module is work for me. 

Remove the x86 configuration seems no work. But it does no matter.

Thank you very much!

Login or Signup to post a comment