Start a new topic

Strange shading of 3D model

Hi all, Do you have my problem when importing fbx model from 3ds max to 3D Encoder? Please see my attachment.

It's strange, the model can show the a pain color without any shading.

(48.6 KB)

Hello Kent,

Could you please send us your .fbx model and make sure that you are using the latest version of our Wikitude 3D Encoder?



Hi Eva,

I am using the latest version of Wikitude 3D Encoder which I have downloaded from your website. Enclosed please find the fbx files. They are exported from 3ds max and Blender.




Good morning,

the files you sent don't produce what you described in your initial post for me. I ran the most recent encoder version on Mac OS X.

The *_3dsmax.FBX file refers to a texture that is not included, therefore the model is rendered black. The *_blender.FBX file is lit by what seems to be a very high intensity white point light source producing very hard lighting.

Your initial post showed a teapot model that apparently suffers from this issue. Would it be possible to have that? With the current set of models, I don't see any issues yet.

- Daniel

I can simulate the same result with the attached fbx files which I've create in 3ds max 2018. Actually, I am using Wikitude 3D Encoder PC version 1.7. It has been downloaded here.


(59.2 KB)


for any lighting calculations to happen you need to have a light source in the scene. For the teapot FBX file that does not seem to be the case to me.

Note that the FBX reviewer tool uses a default light source if you disable lighting or do not have a light source in your scene. This default light source is placed at the current point of observation, causing the object to always be lit. This is why you do get shading in the FBX reviewer tool (and potentially other software as well), but not the Wikitude 3D encoder. If there is no light source, we assume this to be intentional.

- Daniel

Hi Daniel,

I was tried something else but it causes another problems.

Herewith some of my observations:

- I am using single omni light and default setting in 3ds max.

- The modifier is set to 1 and I don't think it's an extreme setting

-  I don't use texture this time so it shouldn't be texture issue

-  I've tried it on both PC and MAC and got the same result

- The shading of teapot in Wikitude 3D Encoder seems like reversed and not smooth

- So do you have any suggestions/guidelines on the lighting setup no matter in 3ds max or Blender?

- I also attached the latest fbx file for your ref





(60.7 KB)


I looked into your files and found the point light to behave quite strangely.

Three things I noticed:

  • The light intensity seems to behave very differently in the 3D encoder and in the SDK. While what I've tried (intensity: 1, inverse square falloff distance: 1m) was completely overexposed in the 3D encoder, it looked somewhat reasonable in the SDK.
  • The point light seems to move about as the camera changes.
  • The point light position seems to not be exported correctly.

All in all the point light seems quite broken. As a quick "fix" I can only recommend using a directional light for the time being while this issue undergoes investigation.

My apologies for the inconveniences.

- Daniel

Eventually, I've resolved this problem... Literally, I work around it...

Actually, the diffuse color and specular color are affecting the strength of the light, but not the 'Multiplier' itself.

It's really tricky, you cannot set these two colors to pure white.


Login or Signup to post a comment