Start a new topic

3D model parts show up black on Iphone

Parts of my 3D model appear to have no texture, this is only on iphone, it works fine on android and i can see the colour, is this something to do with compatibility with iphones or could there be some textures missing from the model?

 

IMG4120.PNG
(1.19 MB)

i can send you a zip file of the app to your email 

Thanks, i changed the lighting position of the model to be at the top and tried tried again with this new model, sometimes the 3D model doesnt load properly(see the image below), although most of the time it does load properly but when it does load properly the animation on the model seems to play very very slowly i only have this problem on Iphones i have tested on multiple different iphones and encountered the same problem, on android the model loads fine and the animation plays as it should. 


I have also attached the wt3 file of the Model
wt3
(2.67 MB)
IMG0031.PNG
(994 KB)

Great. In that case you can simply send it to support@wikitude.com. I'll just have it forwarded to me internally.

Hi Adam,



I just had a look at the content of the model you sent and did not find anything wrong with it. The textures that are referred to in the material file are all there. My guess is, therefore, that this is an issue that requires fixing on our side.


The image you sent also suggests an internal issue. These 'egg-like' shapes appear as a result of faulty handling of OpenGL objects. We've had previous occurrences of them already.


In regards to the slow animation it would be great to have the original FBX file also if that would be possible.


I have to mention, though, that these issues seem to me to be something that cannot be fixed on short notice as they require a non-trivial amount of work. I'll hope we can fit them in the next sprint though.



- Daniel


Hi Daniel 
I have attached the original FBX file, the animation seems to runs fine on the Wikitude encoder and on android devices. Let me know if you dont experience the same animation problem from your end so i can send you a video what it looks like
Thanks 

-Adam

fbx
(6.47 MB)

Also can you give an estimate date or time-frame for the next Sprint as it is really important that we get these issues fixes ASAP
Thanks  

Hi Adam,



the time frame would be about 2-3 weeks for it to be addressed in the next sprint. I'll bring it up tomorrow and see if we can fit it in the current sprint.


I'll keep you updated.



- Daniel


Good morning Adam,



I've looked into this a bit and could not reproduce the slow animation speed, nor did I experience the 'egg'.


As Wikitude is currently participating at AWE Europe I'm a little bit short stocked on devices to test with. Therefore I don't have an iPhone 6 available right now. I tried it on the following devices:


iPhone 5 with iOS 10.3.2

iPhone 6S+ with iOS 11.0

iPad mini Retina with iOS 10.3.2


Is there any additional information on how to reproduce the issue? Which animation specifically is being played slowly? Or is it all of them? For me they seem to be playing at the same speed as in the 3D encoder and in the FBX reviewer.


Also, would it be possible to have your JavaScript file to work with? Maybe there's something special about it that provokes the behaviour.



- Daniel


Hi Daniel 
All the animations are playing slowly, To recreate the problem you can Download our app 'Buzzin' and navigate to the experience page from the side draw and select the Plinth, i have attached the marker that will trigger the model,  I have also made a video of the problem
 https://www.youtube.com/watch?v=azkxz7QyLFQ
https://www.youtube.com/watch?v=rcSiimy--6w      <-- another model which causes the same problem

I have also attached the Javascript File that i am working with

-Adam

js

Hi again Adam,



I ran the JavaScript file you sent on the aforementioned devices and could not reproduce the slow animations. They appear, at least to me, to be played at the exact same speed as in the FBX reviewer tool.


The only thing I changed to get it running is the wtc file path as I do not have yours.


I attached videos of my findings.


Do you have any other iOS devices available other than the iPhone 6 to try this with? If so, do you experience this issue on other devices as well?


Due to the current lack of devices in the office, I'm afraid I'll have to postpone the investigation until Monday.



- Daniel



mov
mov
Login or Signup to post a comment