Start a new topic

Manifest merge problem when building


We installed the Wikitude SDK then tried to build but see the following error...

:processDebugManifest FAILED


Total time: 32.421 secs

FAILURE: Build failed with an exception.

* What went wrong:

Execution failed for task ':processDebugManifest'.

> Manifest merger failed : uses-sdk:minSdkVersion 16 cannot be smaller than version 19 declared in library [:wikitudesdk:] C:\cordova\ARProject\platforms\android\build\intermediates\exploded-aar\wikitudesdk\AndroidManifest.xml

        Suggestion: use tools:overrideLibrary="com.wikitude.architectandlib" to force usage

Hi  Paddy,

The error message indicates the the Android is too small --> sdk:minSdkVersion 16 cannot be smaller than version 19 declared in library. Can you make sue that you follow these system requirements:




OK, managed to fix by editintg platforms\android\androidmanifest.xml

then changing android:minSdkVersion="16" to 19

Login or Signup to post a comment