Start a new topic
Solved

Camera feed not working on iPhone for Instant Tracking

I am using Unity 2017.1of3 with WikiTude SDK 7.0.0. 

While I am able to show the object using instant tracker but the camera feed is not working (see the file attached)

dino.PNG
(254 KB)

4 people have this problem

I get exactly the same issue. It does ask me to allow access to the camera but no camera feed is shown on the screen. It is just black.


1 person likes this

Thanks will wait for the update then. I do need Unity 2017.1


1 person likes this

Is there no way of me using the SDK 7.0 on a newer Unity? My app uses ARKit and ARCore and they need the newer Unity. I bought the Wikitude license to provide an AR experience for the users who do not have a good enough device for ARKit / ARCore, so using an older Unity is not an option for my case.

hey there ,

I'm facing exactly the same problem as Ravi Said, I even tried with Sample Scene without any modification on code or anything else and the problem is still there! I'm using unity 2017.3.0f3 and the latest wikitude unity sdk . by the way my device is xiaomi mi4i and running android 5

There's the screenshot attached below , by the way the app doesn't even ask for camera permission and when I try to close it , it crashes . seems like it's frozen!

The slider can be changed and The buttons are touchable , but nothing happens

Hello,

Did you try with our sample app to see if this is working for you?

Thanks
Eva
Even I am facing above issue with android .apk file no camera feed. What i get is white screen with mesh no camera.

Hi Eva,


Here is the attached messaged from the console.


What do you think?

rtf

I have the same exact error.


I tried Xcode 8, Xcode 9 Beta 5 and Unity SDK 7.0.0 130.7.2017

Unity is 2017.1.0f3


I can't go to Unity 5 either.

Hi,

Could you please tell me which device you are testing so that we can also test?

Thanks
Eva

 

 Hello Ravi,


Based on the screenshot that you sent me I assume that you are actually testing the sample on your computer whereas you should test the sample on a mobile device.


Thanks

Eva

Hi, 


Please try to use Unity 5.6, as it should be compatible with your version of Wikitude.


Thank you,

Alexandru

I am testing with iPhone 7 with IOS 10.0.3.. My Mac has Xcode 8.3.3

Login or Signup to post a comment