Start a new topic
Solved

Camera feed not working on iPhone for Instant Tracking

I am using Unity 2017.1of3 with WikiTude SDK 7.0.0. 

While I am able to show the object using instant tracker but the camera feed is not working (see the file attached)

dino.PNG
(254 KB)

4 people have this problem

Hi Chris,

Unfortunately we can't reproduce it on Android. Did you used our latest version of the SDK (7.1)?


Best regards,

Andreas

Even I am facing above issue with android .apk file no camera feed. What i get is white screen with mesh no camera.

 Hello Ravi,


Based on the screenshot that you sent me I assume that you are actually testing the sample on your computer whereas you should test the sample on a mobile device.


Thanks

Eva

Thanks for replying. I have build .apk and tried just for showing i attached the image . It is coming similar on my android phone as well. Please help me with this issue. Thanks one s again.

 Hello Ravi,


Did you try with our sample (without modifying any part of the code) to see if you still get this issue?


Thanks

Eva

hey there ,

I'm facing exactly the same problem as Ravi Said, I even tried with Sample Scene without any modification on code or anything else and the problem is still there! I'm using unity 2017.3.0f3 and the latest wikitude unity sdk . by the way my device is xiaomi mi4i and running android 5

There's the screenshot attached below , by the way the app doesn't even ask for camera permission and when I try to close it , it crashes . seems like it's frozen!

The slider can be changed and The buttons are touchable , but nothing happens

I am having the same issue  of no camera feed with the unmodified sample. I am running a note 5 with android 7.0 and unity 2017.4.0f1 with the latest wikitude unity sdk

Hello all,


Sorry for not replying faster here. The issue is most likely multithreaded rendering on Android so please, make sure that Multithreaded Rendering is disabled in the PlayerSettings when running on Android.
Support for Multithreaded Rendering will be implemented in a future update.


Thanks

Eva

Hi Eva,


I am having the same problem, but on IOS. I have tried with both Multithreaded support on and off, with the same result. Sometimes the background is white, sometimes it is black, but no camera feed. The grid appears to move according to the phone position changes and I can add objects to the scene. I just cannot see the reality.


I am using:

- the example scene only, without edits.

- iPhone 6

- IOS 11.2.6

- Unity 2017.4.1f1

- xCode 9.3

- Wikitude SDK 7.0


Anythings else I can try?


image




Hi George,


Could you please check to see what errors you are getting in the console log?


In addition, since it is not possible for you to update to a higher version of our SDK, could you maybe try an older version of Unity (for example Unity 5.6 should work).


Thanks

Eva

Hi Eva,


Here is the attached messaged from the console.


What do you think?

rtf

Hi, 


Please try to use Unity 5.6, as it should be compatible with your version of Wikitude.


Thank you,

Alexandru

Is there no way of me using the SDK 7.0 on a newer Unity? My app uses ARKit and ARCore and they need the newer Unity. I bought the Wikitude license to provide an AR experience for the users who do not have a good enough device for ARKit / ARCore, so using an older Unity is not an option for my case.

Login or Signup to post a comment