Start a new topic

Which Android version is REALLY needed for Wikitude 6.1?

Hello,

we developed an app based on the Wikitude GeoBased Javascript methods, Wikitude Version 6.1.
It runs fine on all our devices with Android v5.1.1, 6.x, 7.0 etc.

But on one device, a Samsung Galaxy S3 Mini, with Android 4.1.2,
our app does not start, it shows many errors (see below).

Your documentation sais,
https://www.wikitude.com/external/doc/documentation/6.1/android/supporteddevicesandroid.html
Android 4.0.3 should be enough, but it looks - in our case - like even Android 4.1.2 (API 16) is not enough.

Additionally confusing, at
https://support.wikitude.com/support/discussions/topics/5000077973
Andreas said - already one year ago! :
"With the latest 5.x release of our SDK, Android API level 16  (4.1) is required"

So please tell us,
which Android version do we need as minimum for Wikitude 6.1 ?

Thank you

  Manuel

------------------------------------------------------------------------------

Errors:

I/dalvikvm: Could not find method android.app.Activity.shouldShowRequestPermissionRationale, referenced from method com.wikitude.common.permission.internal.a.checkPermissions
W/dalvikvm: VFY: unable to resolve virtual method 76: Landroid/app/Activity;.shouldShowRequestPermissionRationale (Ljava/lang/String;)Z

I/dalvikvm: Could not find method android.app.Activity.requestPermissions, referenced from method com.wikitude.common.permission.internal.a.checkPermissions
W/dalvikvm: VFY: unable to resolve virtual method 71: Landroid/app/Activity;.requestPermissions ([Ljava/lang/String;I)V

I/dalvikvm: Could not find method android.webkit.WebView.setWebContentsDebuggingEnabled, referenced from method de.fraunhofer.fokus.geoAR.AbstractArchitectCamActivity.onCreate
W/dalvikvm: VFY: unable to resolve static method 16559: Landroid/webkit/WebView;.setWebContentsDebuggingEnabled (Z)V

E/dalvikvm: Could not find class 'android.hardware.camera2.CameraManager', referenced from method com.wikitude.common.camera.internal.c.a
W/dalvikvm: VFY: unable to resolve check-cast 174 (Landroid/hardware/camera2/CameraManager;) in Lcom/wikitude/common/camera/internal/c;

I/dalvikvm: Could not find method android.hardware.camera2.CameraManager.getCameraIdList, referenced from method com.wikitude.common.camera.internal.c.a
W/dalvikvm: VFY: unable to resolve virtual method 883: Landroid/hardware/camera2/CameraManager;.getCameraIdList ()[Ljava/lang/String;

E/dalvikvm: Could not find class 'com.wikitude.common.camera.internal.f', referenced from method com.wikitude.common.camera.internal.CameraService.<init>
W/dalvikvm: VFY: unable to resolve new-instance 2508 (Lcom/wikitude/common/camera/internal/f;) in Lcom/wikitude/common/camera/internal/CameraService;

E/Web Console: Uncaught SyntaxError: Unexpected token (:22
I/Web Console: jQuery error event::4

E/Web Console: Uncaught SyntaxError: Unexpected token =:1317
E/Web Console: Uncaught TypeError: Object Uncaught SyntaxError: Unexpected token = has no method 'includes':8

E/Web Console: Uncaught ReferenceError: World is not defined:73
E/Web Console: Uncaught TypeError: Object Uncaught ReferenceError: World is not defined has no method 'includes':8


Hi Manuel,


there are some places in the Wikitude SDK which do something similar to:

  

if (Build.VERSION.SDK_INT >= 21) {
	CameraManager cameraManager ... // Using API level 21 code which is not reachable with lover versions
} else {
	Camera camera .. // Use old API
}

  

This is working fine on almost all devices (not on the S3 as you can see by the logs). We test with android 4 devices regularly and this issue was never happening.

The solution would be to move the new API code into a different class.


We will take a look into fixing the core issue and include it in one of the upcoming releases.


The problem we are having now is that we do no longer provide fixes to Wikitude SDK 6.1 and the S3 is no longer supported by the Wikitude SDK 7.0 since we raised the minSdkVersion to 19(4.4).


Best Regards,

Alex

Hi,
thank you for the answer.

So what can we do on the Samsung Galaxy S3 Mini?
Do you understand the error messages?
You should get similar problems with a similar device if you start your sample NativeDetailScreen (Geo-based POIs around the viewer).

 

Hi Manuel,


the minSdkVersion required for the Wikitude SDK 6.1. is API level 15. It was lowered from 16 with Wikitude SDK 5.2.

The issue you are describing seems to be a device specific issue.


With Wikitude SDK 7.0 we raised the minSdkVersion to 19.


Best Regards,

Alex

Login or Signup to post a comment